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Introduction 

 
  

 Welcome to Right Hemisphere's Deep UV User Reference. 

Deep UV is a set of tools for the creation and modification of UV mapping for polygonal and sub-
division surface models within an interactive 2D and 3D UV mapping environment. It can be used as a 
standalone application, or with Deep Paint 3D. 

This reference contains detailed information about all the features and capabilities of Deep UV, and is 
organized mainly by functional areas. The User Interface (on page 44) section gives you a guide to 
program controls and where to find them. 

If you have already used previous versions of this program, you might want to start here: Deep UV 
Overview (on page 20). 

If you are new to this software, this would be a good place to start: Getting Started with Deep UV (on 
page 22). 

You can find a guide to using the online reference here: Using the Reference Online (on page 10), and 
below is a list of important introductory topics. 

• UV Mapping (on page 21). 
• Viewports (on page 25). 
• Opening and Closing Files (on page 24). 
• Modifying Preference Settings (on page 27). 
• Selecting UVs (on page 29). 
• Zooming Views (on page 33). 
• Mapping UVs (on page 35). 
• Transforming UVs (on page 39). 
• Undoing and Redoing Actions (on page 41). 
• Exporting UVs and Textures (on page 42). 
• Saving Files (on page 43). 
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Copyright and Trademarks 

Copyright © 2002-2007 Right Hemisphere. 
All rights reserved. 

This software and any accompanying documentation contain the proprietary information of Right 
Hemisphere and its licensors. This software and documentation are provided under a license 
agreement containing restrictions on their use, disclosure, reproduction, transmission and distribution, 
and are protected by copyright law. As stated in the license agreement, reverse engineering of the 
software is prohibited. 

Due to continued product development, the information contained in the documentation may change. 
Right Hemisphere does not warrant the documentation to be error-free. If you find any errors in or 
other problems with the documentation, please report them to Right Hemisphere in writing. 

The product and company names appearing in this software and documentation may be trademarks or 
registered trademarks of Right Hemisphere and third parties. 

Right Hemisphere. 

support@righthemisphere.com (mailto:support@righthemisphere.com) 
http://www.righthemisphere.com (http://www.righthemisphere.com) 

 
 

mailto:support@righthemisphere.com�
http://www.righthemisphere.com/�
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Conventions 

Several user interface controls are utilized within the application, similar to the functionality in most 
Windows applications. These controls are graphical objects that represent the various properties of the 
interface components and functions. Some controls display and allow editing of particular values. 
Other controls start associated commands. Each control has a unique appearance and operation 
designed for a specific form of interaction. 

Help 
Help is accessed from the product menu and, depending on the product you are using, by pressing 
F1. Certain conventions are used within the product and documentation to make them easier to use. 

 
 

Mouse Controls 
The mouse is an intuitive way of interacting with the application. The buttons can be used singularly, in 
conjunction with each other, and in conjunction with other keys on your keyboard to perform a variety 
of functions via shortcuts (on page 89). 

Pressing and holding both mouse buttons is used for a variety of navigation methods including 
zooming in and out from scenes. 

Left-mouse button: Referred to simply as the 'mouse' or 'left-click'. It is used for a number of 
selection functions including selecting objects, menu commands, buttons, and check boxes. 

Right-mouse button: Referred to as 'right-click'. It is used for displaying the right-click menus; the 
available commands differ depending on the position of the cursor in the interface. 

Middle/wheel button: Pressing and holding the middle or wheel button is used to perform certain 
zoom functions. 

 
 

Product Menus 
The product menus are your main means of interacting with the application. Each menu contains 
commands used to perform various functions that relate to the application. Many menus contain sub-
menus and commands. 

Submenu buttons  : Indicates that the selected command includes a submenu. 

On/off toggles : Indicates that the menu command is 'on'. 

Either/or toggles : Indicates that the menu command is the one selected from a group of 
mutually exclusive commands. 

Close buttons : Used to close the current user interface component. For example, the various 
application dialogs. 

Ellipsis : Indicates that a dialog will appear from where you can select various options. 
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Keyboard shortcuts (on page 89): Menus display any available keyboard shortcuts to the right of 
the commands. For example, the File > Open command can be accessed via the keyboard shortcut 
CTRL+O. 
 

Special Controls 
Several special user interface controls are utilized within Deep UV, similar to the functionality in most 
Windows applications. These controls are graphical objects that represent the various properties of the 
interface components and functions. Some controls display and allow editing of particular values. 
Other controls start associated commands. Each control has a unique appearance and operation 
designed for a specific form of interaction. 

Spinners 
A spinner is a control for numeric fields. You can click or drag the spinner arrows to increment or 
decrement the value. 

 

To change a value using a spinner, do any of the following: 

• Click the spinner to increment or decrement the value. 
• Drag up to increase the value, or drag down to decrease it. 
• Press CTRL while you drag to increase the rate at which the value changes. 

Edit Boxes 

 
An edit box is a place where you can enter a value. This value can be a number or a string. Place the 
cursor over an edit box and press the mouse button to activate the edit box. Right-clicking over an edit 
box allows clipboard operations to be used with the edit box, such as Cut, Copy, Paste, Delete, and 
Select All. 

Numeric edit boxes work in conjunction with spinners and sliders, each described below. The number 
of decimal places that are maintained in numeric edit boxes can be set in the Deep UV Configuration 
dialog. 

Edit boxes that take numeric values can have mathematical expressions typed into them. For example 
if you wanted to enter the value 4 divided by 5 you would enter '4/5' (without the quotes), and when 
you press ENTER, the edit box is filled with 0.8. More information about using mathematical 
expressions in edit boxes can be found below. The valid mathematical operators are: 

• * Multiply. 
• + Add. 
• - Subtract. 
• / Divide. 
• ^ Exponent. 

Portions of the mathematical expressions can be grouped together with ( ). Operations within 
parentheses are evaluated first. For example: 

• (4*5)+3 
• 4/4.56 
• (5+67)*(4/3) 
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You can also use the following mathematical functions: 

• sqrt, abs, acos, asin, atan, cos, cosh, exp, log, log10, sin, sinh, tan, and tanh. 

Note: All trigonometric functions use angles measured in radians. 

The following are examples of using mathematical functions: 

• sqrt(0.5) 
• acos(4+4) 

The following constants are also defined: 

• rand = a random number 
• pi = 3.141592654 
• rad = 3.141592654/180.0 
• deg = 180.0/3.141592654 
• mi = 100000.0/2.54/12.0/5280.0 
• km = 5280.0*12.0*2.54/100000.0 

Simply type the constant you want to use: 

• rand 
• (4*pi) 

Sliders 
Sliders work in a similar way to spinners but allow more control over the value. 

 

To use a slider, do any of the following: 

• Drag the slider arrow left to decrease the value. 
• Drag the slider arrow right to increase the value. 

Cyclical Dialog Fields 
Many dialogs contain fields that can cycle through the options every time you click in the field. 

Tabs 
Tabs are analogous to the dividers in a notebook or the labels in a file cabinet. They define multiple 
pages for the same area of a window or dialog box. Each tab comprises a set of information or a group 
of controls that are displayed when you select the corresponding tab. 

Drop Down Lists 

 
A combo box consists of a list box combined with either a static control or edit control. The list-box 
portion of the control can be displayed at all times or can only drop-down when you select the drop-
down arrow next to the control. 
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The currently selected item (if any) in the list box is displayed in the static or edit control. In addition, if 
the combo box has the drop-down list style, you can type the initial character of one of the items in the 
list, and the list box, if visible, highlights the next item with that initial character. 

Buttons 

 
Buttons are controls that start actions or change properties. When you click a command button with 
the primary mouse button, a command is carried out. When you press the mouse button, the input 
focus - a dotted rectangle - moves to the command button, and the command button state changes to 
its pressed appearance. If you move the pointer off the command button while the mouse button 
remains pressed, the command button returns to its original state but still displays the input focus 
rectangle. If you move the pointer back over the command button while pressing the mouse button, 
the command button returns to its pressed state. 

When you release the mouse button with the pointer on the command button, the command 
associated with the control starts. If the pointer is not on the control when you release the mouse 
button, no action occurs. 

Option Buttons 

 
Option buttons represent a single choice within a limited set of mutually exclusive choices. That is, you 
can choose only one of a set of options. Option buttons appear as a set of small circles. When an 
option button choice is set, a dot appears in the middle of the circle. When the item is not the current 
setting, the circle next to the current setting is empty. 

As with command buttons, the mouse interface for choosing an option button requires you to click the 
primary mouse button, either on the option button circle or on its label. When you press the mouse 
button, the input focus moves to the option button label, and the option button displays its pressed 
appearance. If you move the pointer off the option button before releasing the mouse button, the 
option button returns to its original state but retains the input focus. The option is not set until you 
release the mouse button while the pointer is over the control. In addition, repeated mouse clicks on 
the same option button do not toggle the button's state; you need to explicitly select another value in 
the group to change or restore a setting. 

Check Boxes 

 
A check box represents an independent or non-exclusive choice. A check box can have one of three 
states: 

• Checked—The associated value or property is set. 
• Cleared—The associated value or property is not set. 
• Mixed value—The associated value is set for some, but not all, elements of the selection. 

A check box appears as a square box with an accompanying label. When the choice is set, a check 
mark appears in the box. When the choice is not set, the check box is empty 
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When you click a check box with the primary mouse button, either in the check box or on its label, the 
check box is selected and its state is toggled. When you press the mouse button, the input focus 
moves to the control and the check box displays its pressed appearance. Like option buttons and 
other controls, if you move the pointer off the check box or its label while pressing the mouse button, 
the control's appearance returns to its original state and retains the input focus. The state of the check 
box does not change until the mouse button is released. To change a control's setting, the pointer 
must be over the check box or its label when you release the mouse button. 

 
 

Documentation Conventions 
Certain conventions are used within the documentation to make it easier to use: 

• Commands, tools, and selections are displayed in bold typeface. For example, click OK. 
• Menu and submenu commands are separated by the greater-than (>) sign. For example, File 

> Open. 
• Specific keystrokes are represented in capitals. For example, DELETE. 
• Instructions are displayed as numbered steps. 
• Related section headings are displayed in italic typeface if the section is within the current Help 

topic. 
• Related section headings are linked (underlined), to the appropriate section if it is located in 

another Help topic. 
• Where the word 'the application' is mentioned, the content relates to the application that you are 

using. 
• Where the word 'image' is mentioned, the content relates specifically to a 2D representation. 
• Where the word 'scene', 'model', or 'object' is mentioned, the content relates specifically to a 3D 

representation. 
• Where words are displayed within square brackets [ ], substitute the relevant text for the 

described action. 
• Where the plus (+) and minus (-) keys are mentioned, they relate to the number pad and not the 

QWERTY section of the keyboard. 
• Where modules are mentioned, the term refers to products for which modules may be 

purchased. 
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Using the Reference Online 

This reference gives you information about every aspect of the software. Each topic contains an 
overview discussion followed by a 'Procedures' section with steps for using a command or feature, and 
sometimes an 'Interface' section detailing controls and parameters for the user interface. 

Interface 

Topic Overview—Tells you the name of the feature, command, user interface control, or concept, 
and gives you a description. 

Procedures—Contains steps for tasks that illustrate the typical use of the feature. 

Interface—Describes the controls for this feature as they appear in the user interface, with a 
description of their behaviors and settings. 

 
 

Finding Information Fast 
The online information system (Help User Reference) is a compiled HTML Help file and is viewed 
using the HTML Help Viewer. This section explains how to retrieve information quickly. Detailed 
information on using the HTML Help Viewer is explained later in this document. 

Use the Navigation pane in the Help Window to get to information quickly. The pane comprises the 
Contents, Index and Search tabs that let you use search techniques for finding the information you 
need. 

Contents Tab 
The Contents tab displays the main sections of this online system as book icons. When you click a 
book, it expands to show the list of topics contained within it, like chapters in hard-copy books. 

If a book is expanded already, clicking on it collapses the topics. 

Index Tab 
The Index is an alphabetical listing of keywords found in each topic. 

Keywords may be linked to more than one topic. You can also type the first few letters of a subject, the 
whole word or a number of words for which to search. 

Search Tab 
The Search tab summons a full-text search engine that operates on a database of every word in the 
reference, created when the HTML Help system was compiled. You can use tools on the Search tab to 
find the Help topics containing any word or phrase. 

Procedures 

To go to a topic from the Contents tab: 

1. Click the Contents tab to display the table of contents. 

2. Click the book icon representing the area for which you want information. The page icons for the 
book expand below representing all the topics for the book's feature area. 

3. Click the page icon for the topic you want. 
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To go to a topic from the Index tab: 

1. Click the Index tab to display the Help Index. 

2. Do one of the following: 

• Double-click the keywords for which you want to to find information. The topic is displayed in 
the right pane. The topic is displayed in the right pane. 

• Type the subject you want to find in the 'Type in the keyword to find' field and press ENTER. 
The topic is either displayed in the right pane or, if a topic list is displayed, click the topic you 
require and click Display. 

 
 

Using the HTML Help Viewer 
This online information system is a compiled HTML Help (.chm) file; you view it using the HTML Help 
Viewer. The HTML Help Viewer is a two-pane window and a toolbar: 

• The Navigation pane is on the left side of the window. It contains three navigational tabs, for 
Contents, Index and Search. 

• The Topic pane is on the right side of the window. It displays the selected or default Help topic 
and is the pane from which you are reading right now. 

• The Help Viewer toolbar comprises tools from which you can choose to help you use the Help 
Viewer and search for information. 

Following are some tips on how to find more information when using the HTML Help Viewer: 

• To link to another topic or a list of other topics, click the colored, underlined words in the Topic 
pane. 

• Right-click the Contents tab or the Topic pane for shortcut menu commands. 

Note: Most of information about using the HTML Help Viewer has been supplied directly by Microsoft. It has been 
made freely available for inclusion in HTML Help projects such as this one. This information has been edited and 
reformatted to match that of the other online information system delivered with this product. 

Procedures 

To find a Help topic: 

1. In the Navigation pane, do one of the following: 

• Click the Contents tab to browse through a table of contents. 
• Click the Index tab, and then type a word or scroll through the list to see a list of index entries. 

Note: Topics are often indexed under more than one entry. 

• Click the Search tab, and then type the word to locate every occurrence of a word or phrase 
that may be contained in a Help file. 

 

2. Click the contents entry, index entry, or search results entry to display the corresponding topic. 
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To see where the current topic fits in the table of contents: 

While viewing the Index and Search tabs, press ALT+C. The Contents pane is displayed with the 
current topic highlighted. 

To copy a Help topic: 

1. Right-click in the pane of the topic you want to copy, and then click Select All. 

2. Right-click again, and then click Copy. 

3. Paste the copied topic into the document you require. 

To copy only part of a topic: 

Select the text you want to copy, right-click, and then click Copy. 

To print the current Help topic, do one of the following: 

• Click the Print button on the toolbar, select the print options you require, and then click OK. 
• Choose Options > Print on the toolbar, select the print options you require, and then click 

OK. 
• Right-click a topic in the Topic pane and then click Print twice. 
• Right-click a topic name on the Contents tab, click Print, select the print options you require, 

and then click OK. 

To hide or show the Navigation pane: 

On the toolbar, click Hide or Show to close or display the Navigation pane. 

If you close the Help Viewer with the Navigation pane hidden, it is remains hidden when you next open 
the Help. 

 
 

HTML Help Viewer Toolbar 

File > Help 
Keyboard F1 

 
The Help Viewer toolbar contains a number of useful tools including print, refresh, and highlighting 
functionality. 

Interface 

Hide/Show —Hides or shows the Navigation pane. 

Back —Moves to the previously viewed topic. 

Print —Prints the current topic if the Topic pane is active. If the table of contents is active on 
the Navigation pane, you can choose to print the current topic, or the topic and its subtopics. 
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Options —Used to display the 'options' menu and modify the viewing settings. 

• Hide/Show Tabs—Hides or shows the Navigation pane. 
• Back—Moves to the previously viewed topic. 
• Forward—Moves to the topic viewed after the previously viewed topic. 
• Home—Displays the main topic of this online system. 
• Stop—Halts the display of a topic. 
• Refresh—Refreshes the Help display. 
• Internet Options—Opens the Internet Options dialog and is used to modify browser 

settings. We recommend not using this command. 
• Print—Prints the current topic if the Topic pane is active. If the table of contents is active on 

the Navigation pane, you can choose to print the current topic, or the topic and its subtopics. 
• Search Highlight On/Off—Toggles highlighting on and off for each occurrence of a word 

or phrase found with a search. 

 
 

Searching for Help Topics 
A basic search consists of the word or phrase you want to find. You can use Boolean, wildcard, and 
nested expressions. You can also limit the search to previous results, match similar words, or search 
topic titles only to further define your search. 

The basic rules for formulating queries are: 

• Searches are not case-sensitive, so you can type your search in uppercase or lowercase 
characters. 

• You may search for any combination of letters (a through z) and numbers (0 through 9). 
• Punctuation marks such as the period, colon, semicolon, comma, and hyphen are ignored 

during a search. 
• Group the elements of your search using double quotes or parentheses to set apart each 

element. You cannot search for quotation marks. 

Note: If you are searching for a file name with an extension, you should group the entire string in double quotes, 
("filename.ext"). Otherwise, the period breaks the file name into two separate terms and, as the default operation 
between terms is AND, the logical equivalent to "filename AND ext." is created. 
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Searching for Words or Phrases: Using Wildcards 

You can search for words or phrases and use wildcard expressions. Wildcard expressions allow you to 
search for one or more characters using a question mark or asterisk. 

You can select the Match Similar Words check box to include minor grammatical variations for the 
phrase you search. 

The table below describes the results of these different kinds of searches. 

Search for Example Results 

A single word select Topics that contain the word, 'select'. Note that grammatical 
variations, such as 'selector' and 'selection' are also found. 

A phrase "new operation" or 
new operation 

Topics that contain the literal phrase 'new operation' and all its 
grammatical variations. Without the quotation marks, the query is 
equivalent to specifying "new AND operation", which finds topics 
containing both of the individual words instead of the phrase. 

Wildcard 
expressions 

esc* or 80?86 Topics that contain the terms 'ESC', 'escape', 'escalation', and so 
on. The asterisk cannot be the only character in the term. Topics 
that contain the terms '80186', '80286', '80386', and so on. The 
question mark cannot be the only character in the term. 

 
 

Defining Search Terms: Using Boolean Expressions 

The AND, OR, NEAR and NOT operators enable you to precisely define your search by creating a 
relationship between search terms. The following table shows how you can use each of these 
operators. If no operator is specified, AND is used. For example, the query "spacing border printing" is 
equivalent to "spacing AND border AND printing". 

Search for Example Results  

Both terms in the same topic. operation AND parameter Topics containing both the words 
'operation' and 'parameter'. 

Either term in a topic. operation OR parameter Topics containing either the word 
'operation', or the word 'parameter' 
or both. 

The first term without the second 
term. 

operation NOT parameter Topics containing the word 
'operation', but not the word 
parameter. 

Both terms in the same topic, close 
together. 

operation NEAR parameter Topics containing the word 
'operation' within eight words of the 
word 'parameter'. 

Note: The |, &, and ! characters do not work as Boolean operators (you must use OR, AND, and NOT). 
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Using Nested Expressions 

Nested expressions allow you to create complex searches for information. For example, "XML AND 
((operation OR parameter) NEAR configuration)" finds topics containing the word 'XML' along with the 
words 'operation' and 'configuration' close together, or containing 'XML' along with the words 
'parameter' and 'configuration' close together. 

The basic rules for searching Help topics using nested expressions are: 

• You can use parentheses to nest expressions within a query. The expressions in parentheses 
are evaluated before the rest of the query. 

• If a query does not contain a nested expression, it is evaluated from left to right. For example. 
"XML not operation OR parameter" finds topics containing the word 'XML' without the word 
'operation', or topics containing the word 'parameter'. On the other hand, "XML not (operation 
OR parameter)" finds topics containing the word 'XML' without either of the words 'operation' or 
'parameter'. 

• You cannot nest expressions more than five levels deep. 

If you search for words within the HTML files, all HTML topic files are searched, including any that are 
not listed in the table of contents. 

If you search for words that are similar to your search term, you can include minor grammatical 
variations for the phrase you search. For example, a search on the word 'add' finds 'add', 'adds', and 
'added'. This feature only locates variations of the word with common suffixes. For example, a search 
on the word 'add' finds 'added', but not 'additive'. 

If you search only the last group of topics you searched, you can narrow a search that results in too 
many topics found. You can also search through your results list from a previous search. 

When searching for words in Help topics, you can have each occurrence of the word or phrase 
highlighted in the topics that are found. If you are viewing a long topic, only the first 500 instances of a 
search word or phrase are highlighted. 

Procedures 

To go to a topic from the Search tab: 

1. Click the Search tab, and then type the word or phrase you want to find. 

2. Click the 'Boolean' button to the right of the text field, and then one of the operator names to add 
Boolean operators to your search. 

3. If required, do one of the following: 

• To define a search precisely, use a wildcard expression, nested expression, and Boolean 
operators. 

• To request similar word matches, search only the topic titles or search the results of a previous 
search. 

 

4. Click List Topics, choose the topic you want, and then click Display. 

Note: To sort the topic list alphabetically, click the Title column heading. 

To search for words in the titles of HTML files: 

1. Click the Search tab, type the word or phrase you want to find. 

2. Select the Search titles only check box. 

3. Click List Topics, choose the topic you want, and then click Display. 
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To find words similar to your search term: 

1. Click the Search tab, type the word or phrase you want to find. 

2. Select the Match similar words check box. 

3. Click List Topics, choose the topic you want, and then click Display. 

To search only the last group of topics you searched: 

1. On the Search tab, select the Search previous results check box. 

2. Click List Topics, choose the topic you want, and then click Display. 

Note: If you want to search through all of the files in a Help system, this check box must be off. If you 
previously used this feature, the Search tab opens with this check box turned on. 

To repeat an earlier search: 

Click the down arrow on the text-entry field, select a previously used search string, and then click List 
Topics. 

To highlight words in searched topics: 

Choose Options > Search Highlight On on the Help Viewer toolbar. 

To turn highlighting off: 

Choose Options > Search Highlight Off on the Help Viewer toolbar. 

 
 

Keyboard Shortcuts: Help Viewer 
The following keyboard shortcuts can be used for navigation in the Help Viewer. 

Action Keyboard Shortcut 

Close the Help Viewer ALT+F4 

Switch between the Help Viewer and other open windows ALT+TAB 

Display the Options menu ALT+O 

Hide or show the Navigation pane ALT+O and then press T 

Print a topic ALT+O and then press P 
Right-click in the Topic pane and click Print 

Move back to the previous topic ALT+LEFT ARROW 
ALT+O, and then press B 

Move forward to the next topic if you have just viewed it ALT+RIGHT ARROW 
ALT+O, and then press F 

Turn on or off search highlighting ALT+O and then press O 

Return to the home page ALT+O and then press H 

Switch between the Navigation and Topic panes F6 

Scroll through a topic UP ARROW and DOWN ARROW 
PAGE UP and PAGE DOWN 

Scroll through all the links in a topic TAB 
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Contents Tab 

The following keyboard shortcuts can be used for navigation in the Contents tab of the Help Viewer. 

Action Keyboard Shortcut 

Display the Contents tab 

Note: Use this shortcut to see where a topic fits in the table of 
contents. 

ALT+C 

Open and close a book/folder PLUS SIGN and MINUS SIGN 
LEFT ARROW and RIGHT ARROW 

Choose a topic DOWN ARROW and UP ARROW 

Display the selected topic ENTER 

 
 

Index Tab 

The following keyboard shortcuts can be used for navigation in the Index tab of the Help Viewer. 

Action Keyboard Shortcut 

Display the Index tab ALT+N 

Type a keyword for which to search ALT+W and then type the word 

Choose a keyword in the list UP ARROW and DOWN ARROW 

Display the associated topic ALT+D 

 
 

Search Tab 

The following keyboard shortcuts can be used for navigation in the Search tab of the Help Viewer. 

Action Keyboard Shortcut 

Display the Search tab ALT+S 

Type a keyword for which to search ALT+W and then type the word 

Start a search ALT+L 

Choose a topic in the results list ALT+T and then UP ARROW and DOWN ARROW 

Display the selected topic ALT+D 

Search for a keyword in the result list of a prior search ALT+U and press ENTER 

Search for words similar to the keyword. For example, to find words 
like 'running' and 'runs' for the keyword 'run'. 

ALT+M and press ENTER 

Search through topic titles only ALT+R and press ENTER 
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Support 

Online 
Our online support page contains technical support information relating to all of the Right Hemisphere 
products. It provides access to the latest patch releases, tutorials, links to the registration pages, and 
the Right Hemisphere Forum including newsletters, FAQs, and tips and tricks. 

Please take the time to check the support page 
(http://www.righthemisphere.com/support/contact_support.php) if you have any queries before 
sending us an email, in particular, you should check the Knowledgebase 
http://www.righthemisphere.com/support/kb/. It is most likely that the answer is right there! 

Registration and Activation 
If you require assistance with registration or activation, please contact us using our support form 
(http://www.righthemisphere.com/support/contact_support.php). 

Help 
The application User Reference is accessed from the product menu and, depending on the product 
you are using, by pressing F1. It contains detailed information about all the product features and 
capabilities and includes guides to the program controls. 

Silver Support 
Right Hemisphere Client Customers who purchase the Silver Support Plan will get high priority and 
fast resolution to the technical queries. In addition to the complimentary technical support, we provide 
the following supplementary technical support: 

• Direct response to technical queries within one business day 
• Support Availability Monday through Friday 11AM - 6 PM EST 
• Direct contact with our customer support personnel via e-mail AND telephone 
• Software Upgrades - 50% off Retail 
• BETA Program Participation. 

To learn more about the Silver Support Plan, please see the Silver Support 
http://www.righthemisphere.com/support/support_overview.html page on our website. 

 
 

http://www.righthemisphere.com/support/contact_support.php�
http://www.righthemisphere.com/support/kb/�
http://www.righthemisphere.com/support/contact_support.php�
http://www.righthemisphere.com/support/support_overview.html�
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Updating 

Your application can be updated by downloading and running updates from the Right Hemisphere 
Web site. An Internet connection is required to use this option. 

You can check for plugins updates at the Right Hemisphere forum 
(http://www.righthemisphere.com/support/knowledge_base.htm). 

Procedure 

To update your application: 

1. Close all applications. 

2. Go to the Patches page (http://www.righthemisphere.com/support/register/all_reg2.php?ara=1) on 
the Right Hemisphere Web site. 

3. Enter your user name and password. 

Note: You must be a registered user to enter this area of the Web site. 

4. Click Login. 

5. Navigate to the relevant area for the application. 

6. Click Download Now for the update you require. 

7. Save the file to a location of your choice. 

8. Run the .exe file on your computer. 

 
 

http://www.righthemisphere.com/support/knowledge_base.htm�
http://www.righthemisphere.com/support/register/all_reg2.php?ara=1�
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Deep UV Overview 
UV Mapping describes the relationship or 'projection' between a three-dimensional surface point 
(described by X, Y and Z values) and a two dimensional surface point described by U and V values. It 
is useful in describing the relationship between 2D texture maps and their position on a 3D model. 

Deep UV provides enhanced mapping productivity and assists in the creation of distortion-free UV 
mapping for game developers, 3D web content creators and professional 3D artists. 

It allows multiple mapping types to be combined on a single material allowing optimum bitmap usage 
and minimizing distortions and seams. 

Some of the numerous features include: 

• Direct manipulation of texture UVs interactively on 3D models. 
• See real-time updates of UV editing in 2D and 3D viewports. 
• Untangle overlapping UVs instantly. 
• Advanced relax tools to automatically minimize local or global distortions by selection. 
• Advanced interactive 2D and 3D soft selection and feather tools to create selection sets for 

scaling and rotating, etc. 
• UV packing algorithms for faster and closer packing, optimizing the UV space. 
• Merging multiple materials to create a single material with no loss in quality; place all objects 

from an entire scene on a single bitmap to speed loading game textures, while automatically 
preserving the original texture maps. 

• Plugins to send and export back information from 3ds max, LightWave, Maya, and 
SOFTIMAGE|XSI. 

• Full integration with Deep Paint 3D. 
• Automatic interactive VAMP (Variable Angle Multi Patch) and Box mapping to create distortion 

free mapping. 
• Preserve textures while UV editing. Go from one UV mapping to another while retaining the 

existing texture map information. 
• Interactive mapper to dynamically preview unwrapped UV coordinates while altering planar, 

cylindrical, and spherical mapping. 
• A 'lift' function to automatically separate upper and lower UV coordinates. 
• Easy application of different UV map types to different parts of an object or material. 
• Move, scale, rotate, shear, and flip UV data with soft selection for precise control over the area 

of influence. 
• Select UV points, polygons, or groups in 2D or 3D. 
• Advanced 3D selection set features; select surface areas of objects by angle deflection from 

selected faces. Selection sets can be featured by angle. 
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UV Mapping 

UV Mapping describes the relationship or 'projection' between a three-dimensional surface point 
(described by X, Y and Z values) and a two-dimensional surface point described by U and V values. It 
is useful in describing the relationship between 2D texture maps and their position on a 3D model. 

A common example of UV mapping projection can be seen in the problem of representing the earth, 
which is spherical, as flat 2D world map. You can see how the geography closer to the poles is 
distorted. Often the poles are represented by insets showing them from a more suitable projection; 
Deep UV provides tools for performing this type of procedure on 3D objects. That is, separating the 
poles out for a separate projection. 

While Deep UV reduces the expertise needed to deal with UV mapping, understanding UV mapping is 
essential to get the best results when texturing and painting objects. UV mapping can be applied in 
many 3D applications but can be a demanding task for models with complex geometry. 

Even the best efforts in UV mapping can still lead to distorted effects, especially when a complex 
object is mapped. Deep UV provides tools that 'compensate' for distorted UV mapping, and for the 
easy application and modification of UV coordinates, enabling you to get the best results when 
painting and texturing 3D objects. 
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Getting Started with Deep UV 
This section is designed to help you get started with Deep UV. 

Procedure 

To start Deep UV, do one of the following: 

• Click the Windows Start button, choose All Programs > Right Hemipshere> Deep 
UV, and then click Deep UV. 

• Double-click the Deep UV .exe file in Windows Explorer or, if so configured, on your desktop. 

You can now begin using Deep UV (on page 23). 
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Using Deep UV 
Once you have started Deep UV, you can open files, change the view, map objects with UVs, 
transform UVs, and save files. 

This section presents these topics, designed to help you use and understand Deep UV. It also 
introduces you to the Deep UV terminology and some essential features. 

The User Interface (on page 44) section presents the program controls and shows you where to find 
them. 

You can also use a number of external applications (on page 71) to send objects through to Deep UV, 
where they are mapped before exporting the UV or texture information back to your application. 
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Opening and Closing Files 

Menu bar > File > Open 
Keyboard > CTRL+O 
Menu bar > File > Close 

3D files can be opened in Deep UV in a similar way as normal Windows conventions. A progress bar 
is displayed while files are being opened, indicating how long the process is taking. 

Procedures 

To open a file: 

1. Do one of the following: 

• Click File > Open on the menu bar. 
• Press CTRL+0 on your keyboard. 

 

2. Browse for the graphics file and click Open. 

To close a file: 

1. Click File > Close on the menu bar. 

2. If changes have been made to the file, click Yes and continue saving the file (on page 43) in the 
usual way. 
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Viewports 

Deep UV utilizes a workspace that is used to view scenes and images, and to map UVs. The 
workspace consists of file windows that display multiple viewports. 

Windows can comprise multiple viewports as follows: 

• Viewports can be displayed in a variety of layouts (on page 25). 
• Only one viewport can be selected per window. 

Additional files can be opened in separate document windows, and these windows can be displayed 
(on page 47) in a variety of ways. 

When a file is opened in Deep UV, two viewports are displayed in the default viewport layout; a single 
3D viewport and a single 2D viewport: 

• The 3D viewport displays all the objects within the file. It also displays the current 'view type' in 
the top, left corner. 

• The 2D viewport displays one material belonging to the objects, if one exists. It also displays 
current 'view type' in the top, left corner. 

• Material display is repeated if only one or two materials exist, as illustrated in the example 
below. 

Note: It contains various other components that are described in the User Interface (on page 44). 

When 2D images are opened in Deep UV, they are displayed in a single viewport. 

Viewports must be selected (activated) to be able to perform object or material selection, and UV 
mapping procedures. When you click a viewport, it is selected immediately and the viewport frame is 
highlighted in red. 

 
 

Viewport Layouts 

Menu bar > Palette > Layout 

The viewport display can be changed using the Layouts palette (on page 67). The default layout is two 
viewports: 

• A single 3D 'perspective' viewport that displays the objects centered and zoomed to its extents. 
This viewport is selected by default. 

• A 2D viewport that displays one material belonging to the objects, if one exists. 

Any additional materials appear on the Materials panel but are not displayed in a viewport. 

The current 'view type' is displayed in the top, left of each viewport.  

Note: When 2D images are opened, they are displayed in a single viewport. 

The layout can be changed to arrange the viewports in various ways. The active (currently selected) 
viewport remains so when you change the layout. That is, it remains selected. 

The 3D viewport can be displayed using in various 'view types'. For example, models can be displayed 
in perspective, or orthographically from the front. 
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Procedure 

To select a viewport layout: 

Click the layout on the Layouts shelf. The viewports reflect your selection. 

 
 

View Types 

Viewport right-click menu > View 

There are a variety of view types can be used to display the viewports: 

• Top (orthographic) 
• Front (orthographic) 
• Left (orthographic) 
• Underneath (orthographic) 
• Back (orthographic) 
• Right (orthographic) 
• Perspective 
• Orthographic. 

The orthographic views can be used to view 2D and 3D viewports, and are used to view in parallel. 
These views project a single view from a particular viewpoint, onto a drawing surface where the lines 
of projection are perpendicular to the drawing surface. 

The perspective view is used to display models in perspective in 3D viewports. This view displays 
parallel lines as converging to give the illusion of depth and distance. 

Procedure 

To change the viewport view: 

1. Select the viewport. 

2. Right-click the viewport and choose Views. 

3. Click the view you want. 
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Modifying Preference Settings 

Menu bar > File > Preferences 

Various rendering and selection display settings can be modified in the Preferences dialog. 

You can also control the opacity of selected and unselected UVs. This is helpful if you want to highlight 
unselected parts of the objects, and leave selected areas unobscured. 

Note: OpenGL requires power-of-two textures and Deep UV scales non-power-of-two textures so they can be 
used by OpenGL. If you are working with textures that are not a power of two, we recommend selecting the the 
Preferred 2D Renderer 'Software' option. 

Note that Deep UV uses OpenGL's rendering features. These features can be disabled to enable 
correct rendering if the graphics card installed on your computer does not fully support these features. 
For example, if you are using a very old graphics card, you can disable resource sharing and 
information caching. 

Important Note: Disabling these features can significantly degrade performance. We advise using a graphics card 
that supports OpenGL rendering features. 

Procedure 

To modify the preference settings: 

1. Click File> Preferences. 

2. Modify the settings as required in the Preferences dialog. 

3. Click OK. 

Interface 

Rendering tab—Used to modify your render settings. 

• Preferred 2D Renderer—Used to select the renderer to use for materials. 

o Automatic—Swaps between the default Deep UV renderer and OpenGL depending on the 
best selection at the time of rendering. 

o Software—Uses the default Deep UV renderer, and not OpenGL. 

o OpenGL—Uses the OpenGL renderer. 

• Preferred 3D Renderer—Used to select the renderer to use for objects. 

o Automatic—Swaps between the default Deep UV renderer and OpenGL depending on the 
best selection at the time of rendering. 

o Software—Uses the default Deep UV renderer, and not OpenGL. 

o OpenGL—Uses the OpenGL renderer. 

• Compatibility—Used to enable and disable OpenGL features. Note that you must restart 
your computer for compatibility changes to take effect. 

o Share GL Resources—Uses only one copy of the UV and texture information on the 
graphics card for viewing with multiple viewports. 

o GL Model Caching—Stores UV and texture information on the graphics card, and not in 
the system memory, for faster viewport display. 

Selection Display tab—Used to modify the display of selected and unselected UVs in the 
viewports. Note that the Superimpose Selection (on page 69) menu option must be selected for these 
settings to take effect. 
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• Selected Opacity—Used to increase and decrease the opacity of selected UVs. 
• Unselected Opacity—Used to increase and decrease the opacity of unselected UVs.   
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Selecting UVs 

UVs can be selected in the 2D and 3D viewports in a variety of ways. They can be selected via 
materials in the 2D viewports from where you can view the UVs themselves, and they can also be 
selected on objects in the 3D viewport from where you can view the changes made to the textures 
when you modify the UVs. 

Feathering can be used with certain tools (on page 60) to 'soft-select' UVs. That is, to select UVs 
ranging from fully selected to unselected (the selection state). This is helpful when you want to modify 
particular UVs without distorting the surrounding UVs. 

Soft-selected UVs are displayed in a range of colors, depending on their selection state. For example, 
fully selected UVs are displayed in red and unselected are displayed in blue. Semi-selected Uvs may 
be displayed in colors such as yellow, light green or dark green. 

You can reduce selections (on page 46) to seams and non-seams only. Reducing to seams is helpful 
for viewing the structure of tangled UVs containing seams. Reducing selections to non-seams is 
helpful if you want to use the regular relax feature without moving the seams. 

Note that once seams are selected, you can move the UVs into a shape and then 'relax (on page 55)' 
them. 

Selected areas can be displayed with different opacity settings using the Superimpose Selection 
option (on page 69). 

Selecting UVs on Objects 
UVs can be selected on objects and parts of objects in a variety of ways: 

• Using the Objects List rollout (on page 57) to select individual and multiple objects. 
• Using the 'selection mode' tools object parts (points, polygons, components, or elements). 
• Press CTRL+A to select all objects. 
• Press CTRL+D to deselect all objects. 
• Press CTRL+SHIFT+I to inverse the selection. 

If you are selecting parts of objects, you indicate the area you want to select using a 'selection type 
(on page 60)' tool. For example, you could click the Points Selection Mode tool, and then use the 
Rectangular Selection tool to indicate the area in which you want to select points. 

Your selections are reflected in all viewports. 

Selecting UVs on Materials 
UVs can be selected either directly on the material using the various selection tools, or by using the 
Materials List rollout (on page 57). Your selections are reflected in all viewports. 

Keyboard shortcuts (on page 89) can also be used to select materials, invert your selection, and clear 
materials from selection. 
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Selecting Points 

Main toolbar > Point Selection Mode 
Keyboard > SHIFT+P 

Vertices (points) can be selected on objects and materials using the Point Selection Mode  tool. 
Using this tool, only points within the indicated regions are selected. 

Procedure 

To select points: 

1. Click a selection tool on the Tools palette. 

2. Do one of the following: 

• Click Point Selection Mode  on the main toolbar. 
• Press SHIFT+P on your keyboard. 

 

3. Drag over the area which you want to select all points in the viewport. 

4. Do one or more of the following: 

• Hold down SHIFT and select additional areas to select multiple parts. 
• Hold down ALT and select areas to clear those areas from selection. 

 

Selecting Points on Polygons 

Main toolbar > Polygon Selection Mode 
Keyboard > SHIFT+O 

Vertices (points) that are connected by polygons (faces) can be selected on objects and materials 

using the Polygon Selection Mode  tool. Using this tool, only points which share polygons within 
the indicated regions are selected. 

Note: If an edge is selected that joins another in 3D but is separate in 2D, the corresponding 3D edge may be 
displayed in green if you use 'soft' selection (feathering). 

Procedure 

To select faces: 

1. Click a selection tool on the Tools palette. 

2. Do one of the following: 

• Click Polygon Selection Mode  on the main toolbar. 
• Press SHIFT+O on your keyboard. 

 

3. Drag over the area in which you want to select all faces in the viewport. 

4. Do one or more of the following: 

• Hold down SHIFT and select additional areas to select multiple parts. 
• Hold down ALT and select areas to clear those areas from selection. 
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Selecting Components 

Main toolbar > Component Selection Mode 
Keyboard > SHIFT+C 

Components with connecting UVs (vertices attached to a contiguous group of polygons) can be 

selected on objects and materials using the Component Selection Mode  tool. Using this tool, 
only components with connecting UVs within the indicated regions are selected. 

Procedure 

To select components with connecting UVs: 

1. Click a selection tool on the Tools palette. 

2. Do one of the following: 

• Click Component Selection Mode  on the main toolbar. 
• Press SHIFT+C on your keyboard. 

 

3. Drag over the area in which you want to select all components with connecting UVs in the 
viewport. 

4. Do one or more of the following: 

• Hold down SHIFT and select additional areas to select multiple parts. 
• Hold down ALT and select areas to clear those areas from selection. 

 

Selecting Elements 

Main toolbar > Element Selection Mode 
Keyboard > SHIFT+E 

Components with connecting geometry can be selected on objects and materials using the Element 

Selection Mode  tool. Using this tool, only components with connecting geometry within the 
indicated regions are selected. 

Procedure 

To select elements with connected geometry: 

1. Click a selection tool on the Tools palette. 

2. Do one of the following: 

• Click Element Selection Mode  on the main toolbar. 
• Press SHIFT+E on your keyboard. 

 

3. Drag over the area in which you want to select all elements with connecting geometry in the 
viewport. 

4. Do one or more of the following: 

• Hold down SHIFT and select additional areas to select multiple parts. 
• Hold down ALT and select areas to clear those areas from selection. 
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Selecting by Geometry 

Selection tool > Tools Options shelf > Surface Distance 
Selection tool > Tools Options shelf > Angle 
Selection tool > Tools Options shelf > Max Angle 
Selection tool > Tools Options shelf > 3D Distance 

 
Geometry selection options are available for the selection tools (on page 60) that are used to indicate 
the area to select in the viewport. The geometry options can be used in conjunction with the selection 
mode tools (on page 50), for example, Point Selection Mode, to select specific parts of the geometry 
based on the Feather and Resize values. 

UVs can be selected by distance to restrict the selection to surfaces, or allow the selection to extend 
beyond surfaces. 

You can also select UVs using the angle between specific UV points. For example, you could set the 
Resize field to select all UVs within a 5% angle of the UV that is first selected. Any UVs outside of this 
range remain unselected. However, if you increased the Resize field to 100%, all UVs are selected, as 
they all fall within 360 degrees of the original UV point. 

Procedure 

To select elements by geometry: 

1. Click a selection tool on the Tools palette. 

2. Click a selection mode tool on the main toolbar. 

3. Do one of the following: 

• Click Surface Distance  to select UVs based on their distance from the original 
selection along the surface of the model. 

• Click Angle  to select UVs based on the angle between the UV that is first selected, 
relative to all neighboring UVs. 

• Click Max Angle  to select UVs based on the angle between the UV that is first 
selected, relative to the next UV within the selected area. 

• Click 3D Distance  to select UVs based on their distance in 3D space from the original 
selection. 

 

4. Drag over the area in which you want to select the UVs. 

5. Do one or more of the following: 

• Use the Feather slider to modify the UV soft-selection. 
• Use the Resize slider to modify the UV area selection size. 

 

6. Do one or more of the following: 

• Hold down SHIFT and select additional areas to select multiple parts. 
• Hold down ALT and select areas to clear those areas from selection. 

Note: You can click the geometry selection buttons after selecting an area without needing to re-select the 
area. 
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Zooming Views 

Right-click viewport > Zoom Extent 
Right-click viewport > Zoom Selection 
Right-click viewport > Zoom Bitmap 

The magnification of views in both the 2D and 3D viewports can be changed in a number of ways 
using the right-click menus, as described below, and also using the Zoom tool (on page 64). 

Procedures 

To zoom a model or image to its extents: 

1. Select the 2D or 3D viewport. 

2. Right-click the viewport, and click Zoom Extent. 

The entire model or image is displayed within the viewport frame. 

To zoom a selection to its extents: 

1. Select the 2D or 3D viewport. 

2. Make a selection in the viewport. 

3. Right-click the viewport, and click Zoom Selection. 

The selected area is displayed within the viewport frame. 

To zoom a bitmap to its extents: 

1. Select the 2D or 3D viewport. 

2. Right-click the viewport, and click Zoom Bitmap. 

The bitmap is displayed within the viewport frame. 
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Moving UVs, Materials and Objects 

UVs, materials, and objects can be moved within the viewports in different ways: 

• Panning materials and objects (on page 64). 
• Moving UVs (on page 65). 
• Rotating objects (on page 65) around a rotation point. 
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Mapping UVs 

Objects are mapped to minimize distortion and seams to enable paint to be applied more easily. 

In Deep UV, all UV coordinate mapping and editing is done via materials and not objects; a single 
object may have multiple materials and UV mappings, and a single material may span multiple 
objects. 

This section describes the three methods of mapping 3D objects: 

• Automatic mapping: Fastest results. 
• Unwrapping: Fast, yet high quality mapping of complex shapes. 
• Unwrapping using the Interactive Mapper: Highest quality results for planar, 

spherical, polar, and cylindrical shapes. 

For high quality results, you can analyze which parts of your model resemble planar, spherical, polar, 
or cylindrical shapes, use the interactive mapping features to obtain the best mapping for each shape, 
and then use the auto-unwrapping features for complex shapes that do not fall into a specific category. 

 
 

Automatic Mapping 

Command panel > Mapping panel > Global Mapping Operations rollout 

Automatic mapping is the simplest and fastest mapping method. This tool is intended to be used 
before any other mapping tool, as it maps the whole scene regardless of any mapping procedures 
already performed. 

Procedure 

To automatically map a model: 

1. Do one of the following: 

• Open a 3D file directly in Deep UV. 
• Send objects to Deep UV from an external application (on page 71). 

 

2. Position the scene to best select the objects you want to map. 

3. Select the objects you want to map. 

4. Do one or more of the following in the Global Mapping Operations rollout (on page 53): 

• Click Automatic Mapping to map the entire model. 
• Click Preserve Bitmap to move any original bitmap texture data to new UV coordinates. 

Note: This option should be used if the materials were already painted. 

5. Do one or more of the following: 

• Save the file (on page 43) if you opened it directly in Deep UV. 
• Export the UVs and textures (on page 42) if you sent information through from an external 

application. 
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Unwrapping 

Command panel > Mapping panel > Unwrapping rollout 

Unwrapping is used to map complex shapes quickly with high quality. Deep UV's unwrapping styles 
are optimized to perform different mapping functions. 

Procedure 

To map a model: 

1. Do one of the following: 

• Open a 3D file directly in Deep UV. 
• Send objects to Deep UV from an external application (on page 71). 

 

2. Position the scene to best select the objects you want to map. 

3. Select the objects you want to map. 

4. Make your selections in the Interactive (on page 54), Tools (on page 55), and Grid Snap (on page 
55) rollouts. 

5. Use the Interactive rollout (on page 54) if you are mapping planar, spherical, polar, or cylindrical 
shapes. 

6. Select the unwrapping option you want in the Automatic rollout (on page 54). 

7. Click Preserve Bitmap in the Global Mapping Operations rollout to move any original bitmap 
texture data to new UV coordinates. 

Note: This option should be used if the materials were already painted. 

8. Do one or more of the following: 

• Save the file (on page 43) if you opened it directly in Deep UV. 
• Export the UVs and textures (on page 42) if you sent information through from an external 

application. 
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Interactive Mapper 

Command panel > Mapping panel > Unwrapping rollout > Interactive rollout 

The Interactive rollout is used to provide dynamic visual feedback on the UV unwrapping of materials 
using the Interactive Mapper. 

Interactive mapping is the best method for the high quality results when mapping planar, spherical, 
polar, and cylindrical shapes. As the mapper respects the selected UVs, you use it to map different 
parts of the models separately. 

It moved and rotated along the axes using the colored 'movement' squares and 'rotation' circles. 

The XYZ axes, displayed at the bottom of the 3D viewport, can be used for alignment, and the axis 
and seam X, Y, and Z coordinates are used to specify the center of the Interactive Mapper. To align 
the seam (green line) or axis (green square) in a particular direction, rotate the model and use the 
axes as a reference. 

In the example below, the Y-axis is pointing upwards. The seam is pointing down and left, in the +Z 
direction. If you want to move the seam to point it down and right, you would select the Align Seam +X 
option. 

 
3D viewport axis 



38  
 

Procedures 

To display the Interactive Mapper: 

Click Mapping Tool on the Interactive rollout (on page 54). 

To move the Interactive Mapper, do one of the following: 

• Drag the red, green, or blue squares to move the mapper along the respective axes. 
• Drag the yellow square to move the mapper 'freely' in 3D. 

To move the Interactive Mapper: 

Drag a circle up or down to rotate the mapper on the respective axes. 

To align the direction of the axes: 

Click the Align Axis down arrow and click the axis you require. 

To align the direction of the seam: 

Click the Align Seam down arrow and click the axis you require. 
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Transforming UVs 

Menu bar > Edit > Free Transform 
Menu bar > Edit > Transform > Pre-defined transform option 

Selected UVs can be transformed using pre-defined transformation options. They can also be 
transformed freely by scaling, rotating, moving, stretching, and skewing them using the Free 
Transform option. 

When an area is selected using the Transform tool, a rectangle (transform area) is displayed with eight 
handles that are used to manipulate the UVs. The handles are used to resize the rectangle, and the 
axis point can be moved. For example, you can drag inside the transform area to move the UVs. 

 
Transform area 
A: Side handle, B: Corner handle, C: Axis 

Procedures 

To transform UVs: 

1. Select the UVs (on page 29) you want to transform. 

2. Do one of the following: 

• Click Click Edit > Free Transform on the menu bar, modify UVs as required in the 
transform area, and then press ESC. 

• Click Edit > Transform on the menu bar and click the pre-defined transform option you 
require. 

To modify UVs in the transform area, do one of the following: 

• Drag inside the transform area to move the UVs. 
• Drag from outside the transform area to rotate the UVs around the axis point. 
• Drag a side handle or edge into, or out from the center to move the selected edge. 
• Press ALT and drag a side handle or edge into, or out from the center to move the selected and 

opposite edges. 
• Drag a corner handle into, or out from the center to move the selected corner and the two 

adjacent corners. 
• Press ALT and drag a corner handle into, or out from the center to move all corners. 
• Press CTRL and drag a corner handle into, or out from the center to move the selected corner 

only. 
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• Press SHIFT and drag a corner handle into, or out from the center constrain the original aspect 
ratio. 

To move the transform area axis: 

Drag the axis point around the transform area. 

To close the transform area: 

Press ESC. 
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Undoing and Redoing Actions 

Menu bar > Edit > Undo 
Main toolbar > Undo 
Keyboard CTRL+Z 
Menu bar > Edit > Redo 
Main toolbar > Redo 
Keyboard CTRL+Y 

You can undo and redo your UV mapping actions. Undo reverses the last action performed in the 
current file, while redo reverses the last operation performed by the Undo command. 

These actions can be repeated for an unlimited number of times depending on the memory of your 
computer. 

Procedures 

To undo your last action, do one of the following: 

• Click Edit > Undo on the menu bar. 
• Press CTRL+Z on your keyboard. 

• Click Undo  on the main toolbar. 

To redo your last action, do one of the following: 

• Click Edit > Redo on the menu bar. 
• Press CTRL+Y on your keyboard. 

• Click Redo  on the main toolbar. 
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Exporting UVs and Textures 

Menu bar > File > Export > Paint with Deep Paint 3D 
Menu bar > File > Export > Send UV Update 
Menu bar > File > Export > Send Texture Update 

UV and texture information can be sent through to Deep Paint 3D for painting. If a file was sent from 
an an external application to Deep UV, the new UVs and textures can be sent back to the application. 

Please see the External Application Plugins (on page 71) section for information on exporting UVs and 
textures. 

Exporting Rules 
Certain rules exist when exporting UVs and textures: 

• Embedded images cannot be sent to Deep Paint 3D. 
• Protected files  cannot be sent to Deep Paint 3D. 

Procedure 

To export a file to Deep Paint 3D: 

1. Choose File > Export > Paint with Deep Paint 3D. Deep Paint 3D opens. 

2. Click OK. 

You can now paint on the textures and, if required, send the paint information back to Deep UV. 
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Saving Files 

Menu bar > File > Save 
Keyboard > CTRL+S 
Keyboard > CTRL+SHIFT+A 

3D files can be saved in Deep UV into any supported file format (on page 97), similar to normal 
Windows conventions. 

The Save option is used to update the current file by overwriting the last file save. If no file was 
previously saved, this command works like the Save As option; saves the current file under a different 
file name, in another format, and/or to another location. 

If you are working with files sent from external applications (on page 71), depending on the application 
in use, you may be able to save the file in the RH3 format and preserve the UV and texture 
information, then close the application while still working in Deep UV. This is helpful if you want to free 
up computer resources. 

Saving Rules 
Certain rules exist when saving files: 

• Embedded images in RH files are saved when you save to the RH file format. 
• Protected files can only be saved to the RH format. 
• Animation and normals are not preserved when saving to any format, including saving over the 

original RH file. 

Procedure 

To save a file, do one of the following: 

• Click File > Save on the menu bar, or press CTRL+S on your keyboard to update the current 
file and overwrite the last file save. 

• Click File > Save As on the menu bar, or press CTRL+SHIFT+S on your keyboard, select a 
new save location, file name, and/or format for the file, and then click Save. 
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User Interface 
The user interface provides multiple ways to achieve the same goals. It consists of a number of 
components including the menu bar, main toolbar and the Tools Options shelf, the workspace 
(windows and viewports), the Command panel, two palettes, a status bar, and various right-click 
menus. 

Many of the components can be resized, moved and closed similar to the functionality in most 
Windows applications. For example, you can resize the windows by dragging the windows' edges. 

See the topics referenced below for detailed information on all of the user interface components. 

Interface 

Application title bar—Displays the current file name and path. 

Menu bar (on page 45)—Provides access to the main menu commands. 

Main toolbar (on page 50)—Provides quick access to the tools of some of the most common tasks 
in Deep UV. 

Tools Options shelf (on page 51)—Displays all the commands that are available for the selected 
tool. 

Workspace (on page 49)—Consists of file windows that are displayed in multiple viewports. 

Viewports (on page 25)—Displays one 3D viewport, and multiple 2D viewports depending on the 
selected viewport layout. They are used to view and map the current objects and materials. 

Command panel (on page 53)—A floating panel used to access most of the mapping features. 

Tools palette (on page 60)—Provides access to most common tools. 

Layout palette (on page 67)—Used to select the viewport layout. 

Status bar (on page 68)—Displays the progress bar, and information about the selected tool. 

Right-click menus (on page 69)—Sets of commands relating to the standard functionality. 
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Menu Bar 

The menu bar is located directly under the main window title bar. The menu bar uses standard 
Microsoft Windows conventions. 

Note that certain menu options are only available when a file is open. 

File Menu (on page 45) 

Edit Menu (on page 45) 

Select Menu (on page 46) 

Palette Menu (on page 47) 

Window Menu (on page 47) 

Help Menu (on page 48) 

 
 

File Menu 

Menu bar > File 

The File menu contains commands for managing 2D and 3D files, and setting preferences. 

Note: File dialogs (such as Open, Save, Save As) uniformly remember the previous path you used, and default to 
that location. 

Interface 

Open (on page 24)—Opens an existing 2D or 3D file. 

Close (on page 24)—Closes the current file. 

Save (on page 43)—Updates the current file by overwriting the last file save. If no file was previously 
saved, this command works like Save As. 

Save As (on page 43)—Saves the current file under a different file name, in another format, and/or to 
another location. 

Export (on page 42)—Used to export UVs or textures back to the external application from where 
you have sent objects to be mapped. For example, Deep Paint 3D or 3ds max. 

Recent Files—Used to select and open recently open files. The list displays the four most recently 
opened files. 

Preferences (on page 27)—Used to establish your rendering and selection display settings. 

Exit—Quits the program. 
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Edit Menu 

Menu bar > Edit 

The Edit menu contains commands for undoing and redoing actions, and transforming UVs. 

Interface 

Undo (on page 41)—Reverses the last action performed in the current file. 

Redo (on page 41)—Reverses the last operation performed by the Undo command. 

Free Transform (on page 39)—Used to scale, rotate, move, stretch, and skew UVs freely. 

Transform (on page 39)—Used to transform the selected UVs. 

• Rotate 180—Rotates the UV selection 180 degrees. 
• Rotate 90 CW—Rotates the UV selection 90 degrees clockwise. 
• Rotate 90 CCW—Rotates the UV selection 90 degrees counter-clockwise. 
• Rotate 45 CW—Rotates the UV selection 45 degrees clockwise. 
• Rotate 45 CCW—Rotates the UV selection 45 degrees counter-clockwise. 
• Flip Horizontal—Flips the UV selection horizontally. 
• Flip Vertical—Flips the UV selection vertically. 
• Scale by 33%—Scales the UV selection by 33 percent. 
• Scale by 50%—Scales the UV selection by 50 percent. 
• Scale by 75%—Scales the UV selection by 75 percent. 
• Scale by 125%—Scales the UV selection by 125 percent. 
• Scale by 150%—Scales the UV selection by 150 percent. 
• Scale by 200%—Scales the UV selection by 200 percent. 

 
 

Select Menu 

Menu bar > Select 

The Select menu contains commands for selecting UVs, and clearing selection areas in the viewports. 

Interface 

All (on page 29)—Selects all areas within the current viewport. 

Deselect (on page 29)—Clears your all areas within the current viewport from selection. 

Invert (on page 29)—Click this to invert the current viewport selection. 

Reduce Selection to Seams (on page 29)—Trims the current selection to only include points 
that are on seams. 

Reduce Selection to Non-Seams (on page 29)—Trims the current selection to only include 
points that are not on seams. 
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Palette Menu 

Menu bar > Palette 

The Palette menu contains commands to open and close the Tools and Layout palettes. These 
palettes 'float' in the Deep UV workspace by default, and they can be moved around the workspace. 

Procedures 

To open a palette, do one of the following: 

• Choose Palette > Tools to open the Tools palette. 
• Choose Palette > Layout to open the Layout palette. 

To close a palette, do one of the following: 

• Choose Palette > Tools to close the open Tools palette. 
• Choose Palette > Layout to close the open Layout palette. 

• Click the close button  in the top, right corner of the palette you want to close. 

To move a palette: 

Drag the panel by its title at the top of the palette, to the required location. 

Interface 

Tools (on page 60)—Opens and closes the Tools palette. 

Layout (on page 67)—Opens and closes the Tools palette. 

 
 

Window Menu 

Menu bar > Window 

The Window menu contains commands for window display and management. 

Interface 

Cascade—Cascades all open windows in the workspace. 

Tile Horizontally—Tiles all open windows in the workspace horizontally. 

Tile Vertically—Tiles all open windows in the workspace vertically. 

Next—Focuses the selection on the next open window. 

Previous—Focuses the selection on the previous selected window. 

Close—Closes the selected window. You are prompted to save any changes. 

New Window—Opens the selected material in a separate window. 
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Help Menu 

Menu bar > Help 

The Help menu provides access to the application's Help reference system and other helpful 
information. 

Interface 

Help Contents—Displays the application's User Reference. 

Support—Displays the Right Hemisphere Web site support page. 

Keyboard Shortcuts (on page 89)—Displays the keyboard and mouse shortcuts. 

Activate Deep UV—Used to activate Deep UV after registration. This command disappears once 
Deep UV is activated. 

Right Hemisphere—Displays the Right Hemisphere Web site home page. 

About Deep UV—Displays a range of information about Deep UV, including the copyright and 
version information. 
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Workspace 

Deep UV utilizes a workspace that is used to view scenes and images, and map UVs. It consists of file 
windows that display multiple viewports (on page 25). 
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Main Toolbar 

 
The main toolbar provides quick access to the tools of some of the most common tasks in Deep UV. 

Interface 

 Open (on page 24) 

 Save (on page 43) 

 Undo (on page 41) 

 Redo (on page 41) 

 Point Selection Mode (on page 29) 

 Polygon Selection Mode (on page 30) 

 Component Selection Mode (on page 31) 

Element Selection Mode (on page 31) 
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Tools Options Shelf 

The Tools Options shelf is located at the upper, right of your screen, to the right of the main toolbar. It 
displays all the parameters and options that are available for the selected tool (on page 60). 

For example, if you choose a selection tool, various tool parameters and geometry options become 
available as shown below. 

 
Selection tool parameters and geometry options 

The tools parameters and options are controlled using a number of graphic aids. You can adjust 
values using the sliders or the spinners to the right of the numeric fields. 

  
Feather slider bar and spinner: value=12% / value=73% 

Interface 

Sliders—The slider is a graphic control for numeric fields. You can adjust the slider's value by 
dragging the triangle below the slider bar. The triangle turns red when you move it. It represents the 
slider's value, and the value changes as the triangle is dragged. 

Spinners—A spinner is a control for numeric fields. You can click or drag the spinner arrows to 
change the value in the field. 

 
 

Geometry Selection Options 

 
The geometry selection options are displayed when you choose a selection tool from the Tools palette. 
They are used in conjunction with the selection mode tools to select UVs via specific parts of the 
geometry based on the Feather and Resize field values. 

UVs can be selected by distance to restrict the selection to surfaces, or allow the selection to extend 
beyond surfaces. 

You can also select UVs using angle between specific UV points. For example, you could set the 
Resize field to select all UVs within a 5% angle of the UV that is first selected. Any UVs outside of this 
range remain unselected. However, if you increased the Resize field to 100%, all UVs are selected, as 
they all fall within 360 degrees of the original UV point. 

Interface 

 Surface Distance—Selects UVs based on their distance from the original selection along the 
surface of the model. 

 Angle—Selects UVs based on the angle between the UV that is first selected, and the 
remaining UVs (the angle across sharp edges) within the selected area. 
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 Max Angle—Selects UVs based on the angle between the UV that is first selected, relative to 
all neighboring UVs within the selected area. This is helpful for selecting flat surfaces. 

 3D Distance—Selects UVs based on their distance in 3D space from the original selection. 
This is helpful for selecting smooth surfaces. 
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Command Panel 

The Command panel comprises four user-interface panels that give you access to most of the UV 
mapping features of Deep UV. Only one panel is visible at a time. To display a different panel, click the 
relevant tab. 

Various rollouts and sub-rollouts can be used to perform various functions and to select additional 
tools. 

Interface 

Mapping panel (on page 53)—Comprises the Global Mapping Operations, Unwrapping, and 
Packing rollouts. It contains all the options for establishing mapping settings and for creating UVs. 

Objects panel (on page 57)—Comprises the Object List rollout and contains options used to select 
objects for UV mapping. 

Materials panel (on page 57)—Comprises the Material Options and Material rollouts. It contains all 
the options for selecting, merging, and assigning polygons to materials. 

Scene panel (on page 58)—Comprises the Lighting and View Settings rollouts. It contains all the 
options for establishing the lighting and default material settings. 
 

Mapping Panel 

Command panel > Mapping panel 

The Mapping panel contains all the options for establishing mapping settings and for creating UVs. It 
comprises the Global Operations, Unwrapping, and Packing rollouts. 

 
 

Global Mapping Operations Rollout 

Command panel > Mapping panel > Global Mapping Operations rollout 

The Global Mapping Operations rollout is used to map models and preserve painting and texturing 
information. 

Interface 

Automatic Mapping—Automatically maps the entire model. If you then select a section of the 
model, it is highlighted in the material viewport. 

Preserve Bitmap—Moves the original bitmap texture data to new UV coordinates. This option 
should be used if materials have already been painted. 

 
 

Unwrapping Rollout 

Command panel > Mapping panel > Unwrapping rollout 

The Unwrapping rollout is used to apply different types of mapping to object parts, provide dynamic 
visual feedback on the UV unwrapping of materials, minimize distortion, control UV links and 
coordinates, and to control the grid selection of UVs. 

It comprises the Automatic, Interactive, Tools, and Grid Snap rollouts. 
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Automatic Rollout 

Command panel > Mapping panel > Unwrapping rollout > Automatic rollout 

The Automatic rollout is used to isolate different parts of objects to apply different types of mapping. 

For example, you can remove the ears and top of the head of a model for separate planar mapping. 
This allows the head to have a smooth flowing spherical mapping, while areas of high distortion or 
overlap can be planar or VAMP mapped. 

Interface 

Box—Applies symmetrical mapping for symmetric models. This produces the best results for man-
made designs such as cars and boats. 

VAMP—(Variable Angle Multi-Planar Mapping). Applies a local-planar map to groups of polygons. 
This option is best for complex geometry that may be too time-consuming to be mapped by hand. 

Face—Applies a planar map to each individual face for zero distortion with the maximum number of 
seams. 

Unfold—Lays out the selected geometry as a single piece. This option is best used with small pieces 
of geometry that cannot be mapped using the other tools, and is ideal for arms and legs of characters. 
For example, if the VAMP mapping tool creates a large number of pieces and the interactive mappings 
do not fit the geometry. Or, to map a U-shaped tube into a single piece. 

Planar 1—Applies a planar map to automatically minimize distortion. 

Planar 2—Applies mapping similar to the analytic planar 1 map. 

 
 

Interactive Rollout 

Command panel > Mapping panel > Unwrapping rollout > Interactive rollout 

The Interactive rollout is used to provide dynamic visual feedback on the UV unwrapping of materials 
using the Interactive Mapper. 

Interface 

Mapping Tool—Shows and hides the Interactive Mapper. 

Mapping Type—Used to apply an interactive mapping type. 

• Plane—Maps objects similar to its planar shape. This option is best for flat or planar materials. 
• Sphere—Maps objects similar to its spherical shape. This option is best for round materials. 
• Cylinder—Maps objects similar to its cylindrical shape. This option is best for cylinder-shaped 

materials. 
• Polar—Lays out the polygons on the texture map by expanding the 'south pole' of the sphere 

to a circle. This is helpful for mapping heads; by rotating the 'south pole' so it points down the 
neck. 

Centering—Used to center the Interactive Mapper. 

• Model—Centers the Interactive Mapper on the model. 
• Selection—Centers the Interactive Mapper on the current selection. 

Align Axis—Used to orient the axis (green square) direction along the X, Y, Z, or XYZ axes. 

• Position—Used to position an exact center for the mapper by entering X, Y, and Z 
coordinates. 

• Angle—Used to specify exact axes angles for the mapper by entering X, Y, and Z coordinates. 
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Align Seam—Used to orient the seam (red circle) direction along the X, Y, or Z axes. 

Reset—Resets the mapper to its original position and angle. 

 
 

Tools Rollout 

Command panel > Mapping panel > Unwrapping rollout > Tools rollout 

The Tools rollout is used to minimize distortion, and to control UV links and coordinates. 

The Advanced Relax function comprises three 'quick' relax tools to minimize distortion by pinning the 
edges of the selection and relaxing the interior points. 

The Lift function is ideal for automatically mapping the front and rear of a model in one operation. It 
'lifts' front-facing polygons away from back-facing polygons on selected vertices. All front-facing 
polygons are remain the same. All back-facing polygons are flipped horizontally. This is helpful for 
planar mapping and for some cylindrical/spherically mapped objects, such as a character body, where 
the front and back require separate textures. 

Interface 

Relax—Adjusts the shape and size of the selected polygons to match the model geometry. 

Advanced Relax—Used to unfold the selected UVs to minimize distortion and smooth UVs within 
the selected area. 

• Knead Even—Smooths UVs evenly. 
• Knead Aligned—Smooths UVs by aligning them. 
• Knead Hybrid—Smooths UVs using a combination of kneading evenly and alignment. 
• Relax—Adjusts the shape and size of the selected polygons to match the model geometry. 
• Area Greed—Used to select the importance of the UV area when relaxing. Use a low setting 

for high distortion, and a high setting for UVs that unfold easily. 

Join—Forms links between the selected and unselected UVs. 

Cut—Breaks links between the selected and unselected UVs. 

Lift—Automatically separates upper UV coordinates from lower. 

 
 

Grid Snap Rollout 

Command panel > Mapping panel > Unwrapping rollout > Grid Snap rollout 

The Grid Snap rollout is used to control the grid selection of UVs. 

Interface 

Snap to Grid—Snaps the UVs to the specified number of texels (texture pixels). 

Texels—Used to enter the number of texels to which to snap. You can enter a number in the field or 
click a 'number button' to automatically enter that number. For example, if you enter '1', the UVs move 
exact texels. 

Selection to Grid—Moves the selected UVs to points on the grid. 
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Packing Rollout 

Command panel > Mapping panel > Packing rollout 

The Packing rollout is used to automatically arrange groups of UV coordinates to maximize bitmap 
efficiency. It comprises two packing selection options, the Type rollout, and the Options rollout. 

Interface 

Pack Selection—Packs the selection into its containing rectangle. 

Pack All—Packs all UVs on all materials. 

 
 

Type Rollout 

Command panel > Mapping panel > Packing rollout > Type rollout 

The Type rollout is used to choose one of three packing methods with which to pack UVs. The tighter 
the packing method, the more time is taken to calculate large numbers of polygons. 

Tip: For objects with large rectangular faces, it is helpful to map with the automatic VAMP mapping 
option, select the Equal Areas option to line the groups horizontally and vertically, pack once. Then 
select the Preserve Orientation and Space Filling options and pack again. 

Interface 

L-Packer (Fast)—Creates loose packing. This method takes only a short time to calculate large 
numbers of groups of polygons. 

Organic (Fast)—Creates tighter packing. This method takes more time to calculate large numbers 
of groups of polygons than the L-Packer method. For example, it can take several hours for objects 
over 30,000 polygons. We advise using the L-Packer or Rectangle methods when only a small number 
of UV groups are present. 

Rectangle (Medium)—Uses a balanced packing method, somewhere between the L-Packer and 
Organic methods.  

 
 

Options Rollout 

Command panel > Mapping panel > Packing rollout > Options rollout 

The Options rollout is used to re-scale UV groups, preserve orientation information, and control the 
partition space. 

Interface 

Equal Areas—Re-scales UV groups so that the UV area on the bitmap is similar to the UV area in 
3D. 

Note: As the aspect ratio may not be preserved, long, thin UV polygons can result. This can be corrected by 
applying analytic UV mapping. This option also tries to line up the longest axes of UVs groups with the U and V 
coordinates. THis makes it especially useful for packing regular man-made objects with large rectangular faces. 

Preserve Orientation—Preserves any existing group orientations when packing. 

Space Filling—Allows the partitions to stretch to take up more space. This may cause distortion of 
shapes. 
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Spacing—Used to select the amount of space to leave between groups as a percentage. The scale 
depends on the number and shape of groups, and the bitmap size; higher numbers yields looser 
packing. 

 
 

Objects Panel 

Command panel > Objects panel > Object List rollout 

The Objects panel comprises the Objects List rollout and contains options for selecting objects for UV 
mapping. 

Procedures 

To select an object: 

Double-click the object name in the Objects List rollout. 

To clear an object from selection: 

Double-click the name of the selected object in the Objects List rollout. 

Interface 

Objects List rollout—Used to select objects for UV mapping. 

 
 

Materials Panel 

Command panel > Materials panel > Materials Options rollout 
Command panel > Materials panel > Materials List rollout 

The Materials panel contains options for selecting, merging, and assigning polygons to materials. It 
comprises the Material Options and Material List rollouts. 

The Material List rollout shows all objects and the materials assigned to those objects. 

Procedures 

To select a material: 

Double-click the material name in the Material List rollout. 

To clear a material from selection: 

Double-click the name of the selected material in the Material List rollout. 

Interface 

Materials Options rollout—Used to merge materials, assign polygons, and save materials. 

• Merge Selected—Merges all selected materials into one material, and moves all UVs on the 
selected materials onto the new material. 

• Assign to Polygons—Assigns the selected material to all selected polygons. 
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• Save Material—Used to save any changes to the selected material. 

Materials List rollout—Used to select materials for UV mapping. 

Unassigned Materials—Lists materials not assigned to any object. 

 
 

Scene Panel 

Command panel > Scene panel 

The Scene panel comprises the Lighting and View Settings rollouts. It is used to control the direction 
and amount of light that is used in the 3D viewport, and to establish the default material settings. 

 
 

Lighting Rollout 

Command panel > Scene panel > Lighting rollout 

The Lighting rollout comprises the Light Direction and Light Levels areas. It is used to control the light 
direction, and to control the amount of ambient, diffuse, and specular light that is used in the 3D 
viewport. 

Procedures 

To change the diffuse light direction: 

Drag the mouse over the light direction sphere. The light direction is set from the point of where you let 
go of the mouse. 

To change the amount of ambient light: 

Drag the Ambient light slider, or use the spinners to increase or decrease percentage of light. 

To change the amount of diffuse light: 

Drag the Diffuse light slider, or use the spinners to increase or decrease percentage of light. 

To change the amount of specular light: 

Drag the Specular light slider, or use the spinners to increase or decrease percentage of light. 

Interface 

Light Direction—Used to control the direction from where the diffuse light comes. 

Light Levels—Used to control the amount of light within the 3D viewport. 

• Ambient Light—Controls the amount of ambient light in the scene. Ambient light is the light 
that illuminates the entire scene. It has uniform intensity and is uniformly diffuse. It has no 
discernible source and no discernible direction. 
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• Diffuse Light—Controls the amount of diffuse light in the scene. Diffuse color describes how 
a material reflects diffuse light in a scene. Because most scenes contain much more diffuse 
light than ambient light, diffuse reflection plays the largest part in determining overall color. 
Additionally, because diffuse light is directional, the angle of incidence for diffuse light affects 
the overall intensity of the reflection. Diffuse reflection is greatest when the light strikes a vertex 
parallel to that vertex normal. As the angle of reflection increases, the effect of diffuse reflection 
diminishes. The amount of light reflected is the cosine of the angle between the incoming light 
and the vertex normal. 

• Specular Light—Controls the amount of specular (reflection) light in the scene. Specular 
reflection creates highlights on objects making them appear shiny. By setting this color, you 
establish the color of the highlights. 

 
 

View Settings Rollout 

Command panel > Scene panel > View Settings rollout 

The View Settings rollout comprises the Material Override area. It is used to establish the display of 
the default material. The default material can be used to locate any distorted areas on models by 
showing the distribution of UVs. 

Interface 

Material Override—Used to select the type of default material to display. 

• Black—Displays the default material as black. 
• Gray—Displays the default material as gray. 
• White—Displays the default material as white. 
• Small Grey Tile—Displays the default material as small gray tiles. 
• Large Grey Tile—Displays the default material as small gray tiles. 
• Checkerboard—Displays the default material as a checkerboard. 
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Tools Palette 

Menu bar > Palette > Tools 

You can use the selection tools to select an area within the viewport. Various parameters and options 
become available on the Tools Options shelf (on page 51) when you choose a selection tool. 

Interface 

 Rectangular Selection (on page 60) 

 Polygon Wand Selection (on page 61) 

 Lasso Selection (on page 62) 

 Polygonal Selection (on page 63) 

 Pan (on page 64) 

 Zoom (on page 64) 

 Move (on page 65) 

 Rotate (on page 65) 

 
 

Rectangular Selection Tool 

Tools palette > Rectangular Selection tool 

The Rectangular Selection tool is used to select a rectangular area within the viewport. 

 
Rectangular selection 
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Procedure 

To make an rectangular area selection: 

1. Click Rectangular Selection  on the Tools palette. 

2. Select the rectangular parameters on the Tool Options shelf. 

3. Hold down the mouse and drag over the area you want to select. 

Interface 

Back Faces—Includes all back faces in the selection. 

Cross Seams—Includes UV seams in the selection. 

Feather—Softens/fades the edge of the selection. 

Resize—Increases/decreases the size of the selected area. 

 
 

Polygon Wand Selection Tool 

Tools palette > Polygon Wand Selection tool 

The Polygon Wand Selection tool is used to select individual polygons within the viewport. 

 
Polygon Wand selection 
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Procedure 

To make an individual polygon selection: 

1. Click Polygon Wand Selection  on the Tools palette. 

2. Select the polygon wand parameters on the Tool Options shelf. 

3. Hold down the mouse button and drag over the area you want to select. 

Interface 

Back Faces—Includes all back faces in the selection. 

Cross Seams—Includes UV seams in the selection. 

Feather—Softens/fades the edge of the selection. 

Resize—Increases/decreases the size of the selected area. 

 
 

Lasso Selection Tool 

Tools palette > Lasso Selection tool 

The Lasso Selection tool is used to select an irregular area within the viewport. 

 
Lasso selection 
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Procedure 

To make an irregular area selection: 

1. Click Lasso Selection  on the Tools palette. 

2. Select the lasso parameters on the Tool Options shelf. 

3. Hold down the mouse and drag over the area you want to select. 

Interface 

Back Faces—Includes all back faces in the selection. 

Cross Seams—Includes UV seams in the selection. 

Feather—Softens/fades the edge of the selection. 

Resize—Increases/decreases the size of the selected area. 

 
 

Polygonal Selection Tool 

Tools palette > Selection tool 

The Polygonal Selection tool is used to select a select straight-edged area within the viewport. This 
enables you to draw complex shapes. 

 
Polygonal selection 
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Procedure 

To make a straight-edged area selection: 

1. Click Selection  on the Tools palette. 

2. Select the polygonal parameters on the Tool Options shelf. 

3. Hold down the mouse and drag over the area you want to select. 

Interface 

Back Faces—Includes all back faces in the selection. 

Cross Seams—Includes UV seams in the selection. 

Feather—Softens/fades the edge of the selection. 

Resize—Increases/decreases the size of the selected area. 

 
 

Pan Tool 

Tools palette > Pan tool > Drag material/objects 
Tools palette > Move/Zoom/Rotate tool > Press spacebar > Drag material/objects 

The Pan tool is used to move models, images and materials in the viewports. 

Procedure 

To pan materials or objects: 

1. Select the viewport. 

2. Do one of the following: 

• Click Pan  on the Tools palette. 
• Click the Move, Zoom, or Rotate tool and press the spacebar. 

 

3. Drag the material or objects around the viewport. 

 
 

Zoom Tool 

Tools palette > Zoom tool > Drag into/out from scene 
Tools palette > Pan/Move/Rotate tool > Right-click > Drag into/out from scene 
Tools palette > Pan/Move/Rotate tool > Press Z > Drag into/out from scene 
IntelliMouse 

The view in both the 2D and 3D viewports can be magnified or reduced in a number of ways. 

Note: You can also zoom the viewports back to their extents and zoom a selected area using the right-click 
menu (on page 69). 

Procedures 
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To magnify a viewport: 

1. Select the viewport. 

2. Click Zoom  on the Tools palette. 

3. Do one of the following: 

• Drag the mouse into the viewport centre. 
• Select the Pan, Move, or Rotate tool, right-click and drag into the scene. 
• Select the Pan, Move, or Rotate tool, press Z on your keyboard and drag into the scene. 
• Use the IntelliMouse. 

 

The image is magnified until you let go the mouse. 

To reduce the magnification of a viewport: 

1. Select the viewport. 

2. Click Zoom  on the Tools palette. 

3. Do one of the following: 

• Drag the mouse out from the viewport centre. 
• Select the Pan, Move, or Rotate tool, right-click and drag out from the scene. 
• Select the Pan, Move, or Rotate tool, press Z on your keyboard and drag out from the scene. 
• Use the IntelliMouse. 

 

The image is reduced in magnification until you let go the mouse. 

 
 

Move Tool 

Tools palette > Move tool > Drag UVs 
Keyboard > V > Drag UVs 

The Move tool is used to move selected UVs in the 2D viewports. 

Note that if you select and drag UVs in a 3D viewport, the UVs are seen only to move in the 2D 
viewport. However, you can see the texture changes in the 3D viewport. 

Procedure 

To move selected UVs: 

1. Select UVs using one of the selection tools. 

2. Click Move  on the Tools palette. 

3. Drag the mouse around the viewport. 
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Rotate Tool 

Tools palette > Rotate tool > Drag objects 
Tools palette > Pan/Move/Zoom tool > Press R > Drag objects 

The Rotate tool is used to rotate objects in the 3D viewport. 

Procedure 

To rotate objects: 

1. Select the 3D viewport. 

2. Do one of the following: 

• Click Rotate  on the Tools palette. 
• Click the Pan, Move, or Zoom tool, and press R on your keyboard. 

 

3. Drag the objects around the viewport. 
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Layout Palette 

Menu bar > Palette > Layout 

The Layout palette contains a number of buttons with which to select the viewport layout. For example, 
you can display two horizontal viewports, or three small viewports on the right and one large viewport 
on the right. 

The example below shows the window divided into four viewports. 

 
Window divided into four viewports 

Interface 
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Status Bar 

The status bar is located at the very bottom of your screen. It displays the tool name when you move 
your mouse over a tool in the Tools palette. 

For example, if you moved your cursor over the Lasso Selection tool, the tool name is displayed in the 
status bar. 
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Viewport Right-Click Menu 

Right-click viewport > View 

The viewport right-click menus contain commands for the display of the 2D and 3D viewport such as 
the wireframe, texture smoothing, and UV statistics. 

The available options depend on the viewport type. For example, the No Channels option is only 
available for 2D viewports. 

Interface 

Zoom Extent (on page 33)—Zooms a model or an image to its extents. 

Zoom Selection (on page 33)—Zooms a selection to its extents. 

Zoom Bitmap (on page 33)—Zooms a material bitmap to its extents. 

View (on page 26)—Used to select an orthographic or perspective view type. 

• Top—Displays an orthographic view of the scene from the top.  
• Front—Displays an orthographic view of the scene from the front. 
• Left—Displays an orthographic view of the scene from the left. 
• Underneath—Displays an orthographic view of the scene from the bottom.  
• Back—Displays an orthographic view of the scene from the back.  
• Right—Displays an orthographic view of the scene from the right.  
• Perspective—Displays a perspective view of the scene from the current direction. This 

option is only available for 3D viewports. 
• Orthographic—Displays an orthographic view of the scene from the current direction. This 

option is only available for 3D viewports. 

Materials—Used to display a material in the current viewport. 

Note: If you display a material in the Perspective viewport, you can re-display the scene by selecting any of the 
orthographic views. 

Wireframe—Used to display different wireframe views. 

• Show Wireframe—Turns the wireframe display on and off. 
• Standard—Displays the wireframe in light grey. 
• Selection—Displays the selected areas in red and unselected areas in blue. 

Material Override—Overrides the view with the default material. This is helpful for locating 
distorted areas in the model. The default material settings are established using the Scene panel (on 
page 58). 

Texture Smoothing—Turns bilinear filtering on and off; helpful in reducing any 'blockiness'. 

Superimpose Selection (on page 29)—Displays any currently selected areas. The selection 
opacity settings are established using the Preferences dialog (on page 27). 

UV Statistics—Displays the UV statistics in the top, right of the viewport. These include the number 
of polygons and the average UV efficiency. 

Solid—Displays the Solid map. This option is only available for 3D viewports. 

Diffuse—Displays the Diffuse map. This option is only available for 3D viewports. 

Specular—Displays the Specular map. This option is only available for 3D viewports. 
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Bump—Displays the Bump map. This option is only available for 3D viewports. 

Opacity—Displays the Opacity map. This option is only available for 3D viewports. 

No Channels—This is displayed for 2D viewports only, if the objects have no materials. 
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External Application Plugins 
A number of plugins can be installed during the Deep Paint 3D and Deep UV installation processes to 
enable you to work with external applications; by sending objects through to Deep Paint 3D for 
painting and Deep UV for mapping. New UV and texture information can then be exported back to 
your application. 

The supported plugins are: 

• 3ds Max 
• LightWave 
• Maya 
• SOFTIMAGE|XSI 
• Photoshop (Deep Paint 3D only). 

When you install a plugin, you must specify the correct folder path for the external application. If you 
do not specify the correct path, Deep UV tries to locate it, and if it is not found, the path defaults to the 
Deep UV plugins folder for the particular plugin. You must then manually locate it and move it to the 
correct folder. 
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3ds Max Plugin 

Deep UV supports the 3ds Max plugin, versions 4.2, 5.0, 6.0 and 9.0. The plugin is installed by 
selecting the appropriate 3ds Max plugin version during the installation. 

The 3ds Max plugin supports the following export functionality: 

• Save and map polygonal meshes. 
• Save a single material for the entire object. 
• Save per poly-materials of an object. 
• Save multi/sub-object materials. 
• Map mesh-smoothed objects. That is, applying the modifier after the Mesh Smooth so that 

mapping must be performed after any mesh smooth modifications. 
• Map NURBS patches. 
• Set channels individually or simultaneously for mapping selected objects. 
• Create new channels. 

Note: Adding new materials, and material reassignment is not supported. 

If you need to free up computer resources, you can save files to the RH3 format to preserve the UV 
and texture information, then close 3ds Max while still working in Deep UV. You can then import the 
RH3 files back into 3ds Max when required. 

Supported Material Types 
The supported material types are: 

• Standard 
• Multi/Sub-object 
• Blend material: The currently visible material in the viewport is sent when exporting a blend 

material. 
• Double-sided material: The first material, that is, the one on the outside of the object, is 

sent when exporting a double-sided material. 
• Top/Bottom: The material on top or the bottom can be sent when exporting materials using 

the Swap button in 3ds Max. 

Exporting UV Rules 
Certain rules exist when exporting UVs: 

• The default channel, Channel 1 is sent to 3ds Max if the selected UV Channel does not exist. 
• If you select Channel 0, the Vertex Color channel is sent to 3ds Max. 
• If multiple objects are selected, the channel is mapped for all objects. 

UV Modifiers 
Please note the following: 

• We advise having only a single Deep UV modifier on the stack per mapped channel. 
• Ensure you do not have a UV Unwrap on the modifier stack when updating UVs from Deep UV. 
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Enabling the Plugin 
The 3ds Max plugin must be enabled in 3ds Max before the functionality becomes available. 

If you are using both Deep Paint 3D and Deep UV, you need only enable the plugin once. 

Procedure 

To enable the 3ds Max plugin: 

1. Ensure that you installed the 3ds Max plugin during the Deep UV installation. 

2. Open the Utilities panel in 3ds Max. 

3. Click Configure Button Sets button. 

4. Increase the Total Buttons field by one. 

5. Scroll the Utilities button area until you see the new blank button. 

6. Scroll the Utilities list until you see the Right Hemisphere button. 

7. Drag the Right Hemisphere button to the new blank button. 

8. Click OK. The new Right Hemisphere utility button is displayed. 

9. Click the Right Hemisphere button. The Right Hemisphere rollout is displayed. 

3ds Max Plugin Interface 

Map Selection—Sends the selected objects and channels to Deep UV to be mapped. Deep UV 
starts if it is not currently running, and your file is loaded. 

Switch to Deep UV—Opens Deep UV. If the application is already open, it is displayed in front of 
3ds Max. 

Update Bitmaps—Reloads all the bitmaps from disk. 

Mapping Options—Used to select, create, and set UV channels to send to Deep UV for mapping. 

• Channel—Used to select a channel. 
• Auto Create Map—Used to create a new channel for the selected channel number. 
• Set Export Channel—Sets the channel. 

Paint Selection—Sends the selected objects and channels to Deep Paint 3D for painting. Deep 
Paint 3D starts if it is not currently running, and your file is loaded. 

Switch to Deep Paint 3D—Opens Deep Paint 3D. If the application is already open, it is 
displayed in front of 3ds Max. 
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Mapping, Painting and Exporting 
UV mapping, painting, and exporting of UVs and textures is initially performed from within 3ds Max. 
During the procedures you send the file information to Deep Paint 3D for painting and to Deep UV for 
mapping UVs, and then export the updated information back to 3ds Max. 

Note: If you have anything other than a bitmap applied to a channel in 3ds Max it is not exported if textures are 
added in Deep Paint 3D. 

Procedures 

To paint using Deep Paint 3D: 

1. Apply materials to the objects you want to paint. 

2. Select the objects and click Paint Selection in the Right Hemisphere menu on the Utilities 
panel. 

3. Add new textures to the materials and paint on the objects in Deep Paint 3D. 

4. Click Send Materials to 3D Application when you have finished. 

5. Click Save All Maps to save any new textures. 

The textures are updated in 3ds Max and any new textures are added to the material. 

To paint a model using a UV set: 

1. Select the models that you want to paint. 

2. In the Mapping Options rollout in the Right Hemisphere rollout, set the channel selector to the UV 
channels that you want to paint for the models. 

3. Click the map's Set Export Channel button. 

4. Click Paint with Deep Paint 3D. 

5. Paint the models in Deep Paint 3D. 

6. Click Send Materials to 3D Application. 

To map selected objects in Deep UV and export UVs and textures: 

1. Select the objects that you want to map in 3ds Max. 

2. Click Map Selection in the Right Hemisphere rollout to send the objects to Deep UV. 

3. Map your objects in Deep UV. 

4. Do one of the following: 

• Choose File > Export> Send UV Update in Deep UV to export the UVs to 3ds Max. 
• Choose File > Export > Send Texture Update in Deep UV to export the textures to 

3ds Max. 

Note: Use this option if you have reassigned polygons to different materials, or used the Deep UV Merge 
Materials function. 

The UVs or textures are updated in 3ds Max. A new modifier called Deep UV is displayed on the 
modifier stack. 
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To set UV channels in 3ds Max: 

1. Select the objects for which you want to set and export channels. 

2. Select the channel you want to set in the Channel field. 

Note: If you select Channel 0, the Vertex Color Channel is used. If no channel exists, the default channel, 
Channel 1 is used. 

3. Select the Auto Create Map check box to create a new channel if required. 

4. Click the map's Set Export Channel button. The channel is set or created for the selected 
channel number. 

5. Continue setting all the channels for the selected objects. 

You can now map the UV set in Deep UV. 

To map a UV set in 3ds Max: 

1. Click the Map Selection button after you have set the channels. 

2. Map the objects in Deep UV. 

3. Click File > Export> Send UV Update in Deep UV. 

The UVs are updated in 3ds Max. A new modifier called Deep UV is displayed on the modifier stack. 

To set a texture to use a particular UV set in 3ds Max: 

1. Open the Material Editor and select the material you want to view. 

2. Select the texture on the material. 

3. Set a channel number for the texture in the Coordinates rollout. 

4. Click Show map in viewport to view the texture using the new channel. 

To view UV sets in 3ds Max: 

1. Click the model to view the new UVs. 

2. Add the Unwrap UVW modifier to the model. 

3. Set the channel for the UVW modifier to the mapped channel that you want. 

4. Click Edit. 

5. Select a texture in the menu at the bottom of the panel to sort the UVs. 

Note: You can sort the UVs by texture by selecting the texture in the drop-down menu at the bottom of the 
panel. 
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LightWave Plugin 

This plugin enables you to edit materials on objects easily by loading objects directly into Deep Paint 
3D for painting. The bitmaps can then be saved and loaded in LightWave and assigned in the usual 
way. 

Deep UV supports the LightWave plugin, versions 7.0-7.5, version 8.0 and version 9.0. The plugin is 
installed by selecting the appropriate LightWave plugin version during the installation. 

 
 

Enabling the Plugin 
The LightWave plugin must be enabled in LightWave before the functionality becomes available. 

If you are using both Deep Paint 3D and Deep UV, you need only enable the plugin once. 

Note that if you installed LightWave after you installed Deep Paint 3D, you must first copy the Deep 
Paint 3D.p file from the 'LWO' folder where Deep Paint 3D is installed, to your LightWave 'plugins' 
folder. You can then enable the plugin. 

Procedure 

To enable the LightWave plugin: 

1. Ensure that you installed the LightWave plugin during the Deep UV installation. 

2. Copy the Deep Paint 3D.p file from the 'LWO' folder where Deep Paint 3D is installed, to your 
LightWave 'plugins' folder, if you installed LightWave after you installed Deep Paint 3D. 

3. Start LightWave. 

4. Do one of the following: 

• If you are using Lightwave 8.0 or 9.0, choose Utilities > Plugins > Deep Paint 3D. 
• If you are using an earlier version of Lightwave, choose Construct > Additional > Deep 

UV. 
 

5. Browse to the location of the plugin. 

6. Select the plugin and then click Open. 

Right Hemisphere / LightWave Plugin Interface 

Utilities> Additional > Deep UV—Sends the entire scene to Deep UV to be mapped. Deep UV 
starts if it is not currently running, and your file is loaded. 

Send to Deep Paint 3D—Sends the entire scene to Deep Paint 3D to be painted. Only the faces 
which are selected are transported to Deep Paint 3D for painting. If you would like to work on the 
whole model, you can leave it unselected. Only visible geometry layers are sent to Deep Paint 3D, if 
you have segmented a model into parts using the Layer panel, you can select which parts to paint. 

Retrieve Textures—Saves all image maps in Deep Paint 3D and then reloads the images into the 
Modeler. When you send a model to Deep Paint 3D, it uses the same external image files that are 
used by your original model in LightWave. For example, LeftFootBump.tga. 

Note: Ensure you save any changes made in Deep Paint 3D. This can not be undone once the image files are 
saved. 

Surface Editor—Used to launch Lightwave's surface editor. 
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Mapping, Painting and Exporting 
UV mapping, painting, and exporting of UVs and textures is initially performed from within LightWave. 
During the procedures you send the file information to Deep Paint 3D for painting and to Deep UV for 
mapping UVs, and then export the updated information back to LightWave. 

You can add new textures in Deep Paint 3D by clicking the empty channels in the material view. When 
you click Retrieve Textures, any new textures are automatically assigned to the appropriate 
surfaces. However, before you return to the Modeler to retrieve the textures, use Deep Paint 3D's File 
> Save All Maps option to choose appropriate names for your new files. 

Consider the following when painting in Deep Paint 3D: 

• Only send your model to Deep Paint 3D once. After it in loaded in Deep Paint 3D, you can 
move between the two applications and select one of two retrieve buttons to view your 
changes. 

• If you are using patches or polygons with more than three sides, the plugin temporarily freezes 
and triangulates them in order to create a model that Deep Paint 3D can use. The plugin uses 
the undo buffer to restore the model to it's original state, so ensure you have 'Undo Levels' set 
to at least 2 in the general options (press 'o' to see the general options in the Modeler). 

• If Deep Paint 3D appears slow when painting on patches, ensure the number of patch divisions 
is not set too high in general options. A setting of 8 produces good results. 

Procedures 

To paint using Deep Paint 3D: 

1. Create surfaces shaders for the model in LightWave. 

2. Create UV's for the model and assign them to the surfaces' shaders using the surface editor. 

3. Add a texture to the surface shader. 

Note: You must have at least one texture on your shader for UV's to be sent to Deep Paint 3D. 

4. Do the following to automatically assign textures, if no textures are assigned to your model. 

• Send the model to Deep Paint 3D. 
• Add textures to the materials. 
• Click File > Save All Maps. 
• Check the compacted layers and generate new bitmaps. 
• Select not to backup the existing file. 
• Click Save all maps automatically to create names for textures, select a destination 

directory in which to store the new texture maps, and the click OK. 

Note: If you leave this clear, you can manually type in the names for each texture map. 

• Go back to LightWave and click Retrieve textures in the Deep Paint 3D dialog. The 
textures are loaded and assigned to your model. 

• Close the model in Deep Paint 3D and export it to LightWave again. 

To map selected objects in Deep UV and export UVs and textures: 

1. Select the objects that you want to map in LightWave. 

2. Choose Utilities> Additional > Deep UV. 

3. Map your objects in Deep UV. 

4. Do one of the following: 
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• Choose File > Export> Send UV Update in Deep UV to export the UVs to LightWave. 
• Choose File > Export > Send Texture Update in Deep UV to export the textures to 

SOFTIMAGE|XSI. 

Note: Send texture updates if you have reassigned polygons to different materials, or used the Deep UV 
Merge Materials function. 
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Maya Plugin 

Deep Paint 3D and Deep UV supports the Maya plugin, versions 3.0, 4.0, 4.5, 5.0, 6.0 and 8.0. The 
plugin is installed by selecting the appropriate Maya plugin version during the installation. 

Note: In certain situations, you need to manually install the Maya plugin (on page 79). For example, if you 
downloaded a new Maya plugin from the Right Hemisphere Web site. 

If you need to free up computer resources, you can save files to the RH3 format to preserve the UV 
and texture information, then close Maya while still working in Deep Paint 3D or Deep UV. You can 
then import the RH3 file back into Maya when required. 

Compatibility 
The Maya plugin is compatible with Maya Unlimited, Maya Complete, and Maya Builder. This table 
shows the Maya application versions and their compatibility with Deep Paint 3D and Deep UV. 

Version Compatibility 

Maya 1.5 Discontinued 

Maya 2.0 No 

Maya 2.5 No 

Maya 3.0 Yes 

Maya 4.0 Yes 

Maya 4.5 Yes 

Maya 5.0 Yes 

Maya 6.0 Yes 

Maya 8.0 Yes 

Material Splitter 
After the plugin is installed and enabled, the Material Splitter includes a dialog used to assign shaders 
and bitmaps to objects before sending them to Deep Paint 3D. It assigns textures to the five channels 
used by Deep Paint 3D, and it assigns shading switches to the shaders and then adds the connected 
objects to that shading switch. 

You can specify how large you want the textures to be, and their file type from within the Bitmap 
options. Then, by clicking the arrow in the appropriate channel, and clicking Assign Shading Switch, 
the shading switch for that material or shader is created, and texture maps for the objects connected 
to that material are attached. 
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Manually Installing the Maya Plugin 
You must manually install the Maya plugin if you: 

• Did not install the Maya plugin when you installed Deep Paint 3D or Deep UV. 
• Installed Maya after installing Deep Paint 3D or Deep UV. 
• Downloaded a new Maya plugin from the Right Hemisphere Web site. 

Procedure 

To manually install the Maya plugin: 

1. Ensure that Maya, Deep Paint 3D, and Deep UV are closed. 

2. Open Windows Explorer. 

3. Copy the RightHemisphere.mll from the Maya directory on the Deep Paint 3D or Deep UV 
installation CD, or from the Files directory in the downloaded .zip file to the existing Maya 'plugins' 
folder. 

4. Copy RightHemisphere.mel from the same location to the existing Maya 'scripts\others' folder. 

Important Note: The 'mel' file must be copied to the 'scripts\others' folder, not the 'scripts' folder. 

 
 

Enabling the Plugin 
The Maya plugin must be enabled in Maya before the functionality becomes available. 

If you are using both Deep Paint 3D and Deep UV, you need only enable the plugin once. 

Procedure 

To enable the Maya plugin: 

1. Ensure that you installed the Maya plugin during the Deep UV installation. 

2. Start Maya. 

3. Do one of the following: 

• If you are using Maya 8.0, choose Window > Settings/Preferences > Plugin 
Manager 

• If you are using a version of Maya prior to 8.0, choose Window > General Editors > 
Plugin Manager. 

 

4. Select the RightHemisphere.mll's 'loaded' check box. 

5. Select the RightHemisphere.mll's 'auto load' check box if you want the plugin to load every time 
you start Maya. 

6. Click Close. 
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Right Hemisphere / Maya Plugin Interface 

Material Splitter—Used to assign textures to the five channels used by Deep Paint 3D. 

Map All with Deep UV—Sends the entire scene to Deep UV to be mapped. Deep UV starts if it is 
not currently running, and your file is loaded. 

Map Selected with Deep UV—Sends the selected objects and channels to Deep UV to be 
mapped. Deep UV starts if it is not currently running, and your file is loaded. 

Launch Deep UV—Starts Deep UV. If the application is already open, it is displayed in front of 
Maya. 

Map All with Deep Paint 3D—Sends the entire scene to Deep Paint 3D to be painted. Deep 
Paint 3D starts if it is not currently running, and your file is loaded. 

Map Selected with Deep Paint 3D—Sends the selected objects and channels to Deep Paint 
3D to be painted. Deep Paint 3D starts if it is not currently running, and your file is loaded. 

Launch Deep Paint 3D—Starts Deep Paint 3D. If the application is already open, it is displayed in 
front of Maya. 

Import UVs—Imports all UVs. 

Update Materials—Creates new materials in Maya if they are required, and attaches any new 
textures to materials. 

Update File Textures—Reloads all the bitmaps from disk. 

 
 

Mapping and Exporting 
UV mapping and exporting of UVs and textures is initially performed from within Maya. During the 
procedure you send the file information to Deep UV where you map the UVs, then export them and 
any texture updates back to Maya. 

Deep UV supports the export of polygons for both full and partial objects. You can assign polygons to 
different materials in Deep UV and the polygons are re-assigned back in Maya. It is possible to select 
the current UV set that you wish to map before exporting to Deep UV. 

Note: Sub-division UVs are not supported. 

Construction History 
If you want to map models using Deep UV, ensure nothing is connected to the .inMesh attribute of 
your model by deleting your construction history in Maya. You can then attach shaders to the model, 
use the Material Splitter to add shading switches and textures, and send the model to Deep UV for 
mapping. 

We advise backing up your Maya scene before exporting UVs if you want to restore your construction 
history. 

Important Note: To update an object's UVs, the construction history for that object must be deleted. 

Before you export from Maya, you should set the UVs with which you want to work. 
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Procedures 

To map selected objects in Deep UV and export UVs and textures: 

1. Select the objects that you want to map in Maya. 

2. Choose Edit > Delete By Type > History. 

3. Click Map selected for Deep UV from the Right Hemisphere Maya plugin menu to send the 
objects to Deep UV. 

4. Map your objects in Deep UV. 

To set different UVs in Maya and map them in Deep UV: 

1. Choose Window > UV Texture Editor in Maya. 

2. Select the objects that you want to map in Maya. 

3. Choose Edit > Delete By Type > History. 

4. Choose Image > UVSets in the UV Texture Editor window, and select the UV set that you 
want to map. 

Note: You can repeat this process and change the default UV set for other objects in Maya. 

5. Continue setting all the channels for the selected objects. 

6. Click Map Selected with Deep UV from the Right Hemisphere plugin menu. 

You can now map the objects in Deep UV. 

 
 

Subdivisional Surfaces, Shaders and Shading Switches 
You can use Deep Paint 3D to paint on subdivisional surfaces (Sub-D's), add directly to shaders (not 
using shading switches), and to use shading switches. 

Procedures 

To paint on subdivisional surfaces 

1. Create a subdivisional surface. 

2. Assign shaders to the Sub-D. 

3. Map the model using the Maya Sub-D texture mapping tool. 

4. Save the scene. 

5. Select the Sub-D. 

6. Choose Right Hemisphere > Paint Selection. 

7. Paint the model in Deep Paint 3D. 

8. Click Send Back to 3D Application in Deep Paint 3D. 

To add directly to shaders: 

1. Select your objects and export them to Deep Paint 3D. 

2. Add textures to the channels that you want to map. 

3. Click Send Back to 3D Application. 
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4. Do the following in the resulting dialog: 

•  Check Generate New Bitmaps. 
•  Clear the Backup Existing File check box. 
•  Check the Save Maps Automatically check box. 
•  Select a destination directory in which to place the textures. 
•  Select OK. 

 

5. Go into Maya. The textures have been added. 

6. Save your Maya scene. 

7. Go into Deep Paint 3D and paint the scene. 

8. Click Send Materials to 3D Application. 

The textures automatically refresh in Maya. 

To use shading switches: 

1. Apply the shader to the objects that you want to paint. 

2. Create a 'Triple Switch' from the Switch Utilities menu. 

3. Hold down the middle mouse and drag from the switch to the shader. The triple switch node is 
connected to the shader's color attribute. 

4. Select the color. 

5. Select your objects and export them to Deep Paint 3D. 

6. Select the Batch Mode check box and click the color channel in Deep Paint 3D. 

7. Proceed through the dialogs and add the texture maps. 

8. Repeat these procedures for the other channels you want to map. 

9. Use the material splitter to perform steps 1-7. 

10. Click the Send Materials to 3D Application. 

11. Do the following in the resulting dialog: 

•  Check Generate New Bitmaps. 
•  Clear the Backup Existing File check box. 
•  Check the Save Maps Automatically check box. 
•  Select a destination directory in which to place the textures. 
•  Select OK. 

 

12. Go into Maya. The textures have been added. 

13. Save your Maya scene. 

14. Go into Deep Paint 3D and paint the scene. 

15. Click the Send Materials to 3D Application. 

The textures automatically refresh in Maya. 
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Closing Applications and Establishing Connections 
When you send scene information from Maya to Deep UV, you can close Maya and continue mapping. 
When you finish mapping, you can reopen Maya using the Establish Connection option to ensure 
Maya receives commands from Deep Paint 3D and Deep UV.  

Now you can reload the scene that was sent to Deep UV. 

Ensure you select the objects for which you want to update UVs within Maya. Select all of the objects 
in Maya if you are unsure. You must also ensure nothing is attached to the .inMesh attribute of your 
models. Note that if you are not using shading switches, you can delete your construction history to do 
this. You then select File > Export > Send UV Update from within Deep UV, and the updated UVs are 
displayed in Maya. 

When you export the UVs from Deep UV, ensure the original scene is open in Maya, or the UVs will 
only be sent to Deep Paint 3D. When you are finished, restart Maya and the scene that you exported 
to Deep Paint 3D, and click Send to 3D Application in Deep Paint 3D.  

Important Note: Deep Paint 3D does not send back UVs. 

You can now choose the Establish Connection option from the Right Hemisphere menu. 

Material Splitter and Shading Switch 
Maya has an issue on Windows 2000 and NT platforms, relating to shader assignment information if 
shading switches are in use. If you are using shading switches, you must not delete your construction 
history after you have added the shading switches. 

Suggested Workflow for Deep Paint 3D and Deep UV 
1. Create your models. 

2. Ensure nothing is connected to the .inMesh attribute of the models when you are ready to map 
them in Deep UV. 

Note: Deleting your construction history does this for newly created models in Maya. 

3. Attach all your shaders to the models, and then use the Material Splitter to add shading switches 
and textures. 

Note: You can also do this by hand. 

4. Export the models to Deep UV. 

5. Map the models and then choose File > Send UV Update. 

6. Export the models from Maya to Deep Paint 3D for painting. 

 
 

Hints and Tips 
This section contains hints on using Deep Paint 3D and Deep UV in conjunction with Maya. 
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Exporting to Deep Paint 3D 
When you export to Deep Paint 3D, add an image from disk to one of the channels in Deep Paint 3D, 
then try to export back to Maya, Deep Paint 3D does not use the newly added file and you are 
prompted to save the file to disk. 

This is because Deep Paint 3D uses a layering system. If there are any existing images in the 
channels when you send information from Maya to Deep Paint 3D, Deep Paint 3D uses these files as 
the destination for the final images. However, if you load in an image from disk, Deep Paint 3D does 
not see this as a final image, it sees it as an image in a layer. 

When you try to send it back to Maya, it has no file path for the final image of the compacted channel. 
That is, it has to compact all the images from every layer that are in that channel into one single 
image. Deep Paint 3D then requires a save destination in which to save the image. 

Polygons, NURBS and Subdivision Surfaces 

• You can export both full and partial models to Deep Paint 3D for painting. 
• You can export NURBS surfaces to Deep Paint 3D. They are tessellated based on the settings 

in Modify > Convert > NURBS to Polygons. 
• You can export subdivisional surfaceS to Deep Paint 3D. Currently, tessellation settings are 

adaptive with divisions per face set to '3'. 

Importing 
If you experience difficulties when importing, consider doing the following: 

1. Re-establishing the connection. 

2. Performing the following procedures: 

• If sending a UV update from Deep UV is unsuccessful, choosing the Import UVs option in 
Maya. 

• If you performed a preserve bitmap operation in Deep UV, choosing the Send Texture Update 
option in Deep UV, and then the Update File Textures option in Maya. 

• If you re-assigned polygons to different materials in Deep UV, or used the Deep UV Merge 
Materials function, choosing the Send Texture Update option in Deep UV, and then the Update 
Materials option in Maya. 

Manual Maya Plugin Installation 

Maya Plugin Manager 

If you cannot see RightHemisphere.mll in the Maya Plugin Manager, ensure that the 
RightHemisphere.mll file is located in the Maya 'plugins' folder. 

Maya Exporter Link 

If the Maya exporter does not link to 'CreateRightHemisphereMenu' when you start the Maya / Deep 
Paint 3D plugin, ensure the RightHemisphere.mel file is located in the 'scripts\others' folder and not 
the 'scripts' folder, as Maya does not browse the scripts folder for this file. 

Error Messages 

The Maya script-editor may display the following error messages when you click the 
RightHemisphere.mll: 

• Error: No plug-ins loaded—"The specified procedure could not be found". 
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• Error: Cannot find procedure "CreateRightHemisphereMenu'. 

To correct this, ensure the RightHemisphere.mel file is located in the 'scripts\others' folder. 

Loading the Maya / Deep Paint 3D Plugin 

If you have difficulties loading the Maya plugin, do the following: 

1. Ensure that the RightHemisphere.mll is in your Maya 'plugins' folder. 

2. Ensure that the RightHemisphere.mel is in your Maya 'scripts\others' folder. 

3. Try loading the Maya plugin again. 

4.  If you continue to have difficulties, contact Right Hemisphere support 
(http://www.righthemisphere.com/support/contact_support.php) with your Maya version number 
and the date of 'RightHemisphere.mll'. 

Material Features 
You can add new channels to materials in Deep Paint 3D to be added in Maya. Deep Paint 3D also 
adds materials to objects with shading switches on. 

Material Splitter 

Error Messages 

You may receive an error message, similar to the one below, when using the material splitter on an 
object: 

• Warning: Texture file "blinn1.groupA|mySphere.Color.tif doesn't exist". 

This is because two objects in a scene can have different parents, but still have the same name. 

For example, a scene could have two spheres named mySphere. One sphere could have a parent 
'GroupA', and the other sphere could have no parent at all. As the two objects have the same name, 
Maya places the pipe character (|) between the group name and the object name to provide a unique 
name for the material splitter. The pipe character, however, is not a valid character for use by 
Windows. The material tries to create a texture with groupA|mySphere in its name. 

To correct this, you must ensure that every object in your scene has a unique name. 

For example, you could create two legs by creating two groups, left_leg and right_leg. You then create 
the parts of each leg for the left and right legs. The parts should be given unique names for each leg. 
TO do this, you could simply add the words Right and Left to the beginning of each part name, 
LeftAnkle, RightAngle, LeftFoot, and RightFoot, etc. 

Maya Running on Irix 
We are unable to support Irix. However, Deep Paint 3D has excellent OBJ file format (Wavefront) 
support. 

The Maya plugin does operate on Irix computers, so you can export your models to a network drive 
that is visible to your Windows 98/2000/NT computer, then load the OBJ file into Deep Paint 3D, paint 
on it, and then save it. 

Saving Files 
Deep Paint 3D can include many layers in a scene, and image that are saved are compacted versions 
of all the layers. If you cannot save to a format other than DP3 in Deep Paint 3D, you may have to 
compact all the layers before saving. 

 

http://www.righthemisphere.com/support/contact_support.php�
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SOFTIMAGE|XSI Plugin 

Deep UV supports the SOFTIMAGE|XSI plugin, versions 3.0, 3.5, and 4.0. The plugin is installed by 
selecting the appropriate SOFTIMAGE|XSI plugin version during the Deep UV installation. You can 
then enable the plugin in SOFTIMAGE|XSI. 

Note: For SOFTIMAGE|XSI version 3.0, you must have Deep Paint 3D version 2.1 or higher. 

 
 

Enabling the Plugin 
The SOFTIMAGE|XSI plugin must be enabled in SOFTIMAGE|XSI before the functionality becomes 
available. 

If you are using both Deep Paint 3D and Deep UV, you need only enable the plugin once. 

Procedure 

To enable the SOFTIMAGE|XSI plugin: 

1. Ensure that you installed the SOFTIMAGE|XSI plugin during the Deep UV installation. 

2. Start SOFTIMAGE|XSI. 

3. Choose File > Add-On > Install. 

4. Browse to the location of the plugin. 

5. Select the plugin and then click OK > Install. 

Right Hemisphere / SOFTIMAGE|XSI Plugin Interface 

File > Export > Deep UV—Sends the entire scene to Deep UV to be mapped. Deep UV starts if 
it is not currently running, and your file is loaded. 

 
 

Mapping, Sending and Exporting 
UV mapping and exporting of UVs and textures is initially performed from within SOFTIMAGE|XSI. 
During the procedure you send the file information to Deep UV where you map the UVs, and then 
export them and any texture updates back to SOFTIMAGE|XSI. 

Procedures 

To paint selected objects in Deep Paint 3D and export the updates: 

1. Assign a material to the objects. 

2. Assign an image to the channel that you want to paint. For example, the Diffuse channel. 

3. Create a new texture projection to give the objects a UV map. 

4. Click Page Up to move back up a level. 

5. Choose File > Export > Deep Paint 3D. The objects are exported with a bitmap and a UV 
map ready for painting. 

6. Paint the objects. 
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7. Choose File > Export > 3D Application to export the updates back to SOFTIMAGE|XSI. 

To map selected objects in Deep UV and export UVs and textures: 

1. Select the objects that you want to map in SOFTIMAGE|XSI. 

2. Choose File > Export > Deep UV. 

3. Map your objects in Deep UV. 

4. Do one of the following: 

• Choose File > Export> Send UV Update in Deep UV to export the UVs to 
SOFTIMAGE|XSI. 

• Choose File > Export > Send Texture Update in Deep UV to export the textures to 
SOFTIMAGE|XSI. 

Note: Send texture updates if you have reassigned polygons to different materials, or used the Deep UV 
Merge Materials function. 
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Keyboard Shortcuts 
This section shows the pre-assigned keyboard shortcuts; keyboard alternatives to program functions. 
It also describes any shortcuts that can be accessed using the mouse buttons. 

If a keyboard shortcut is available for a command, it is displayed to the right of the command name on 
the menu. 

Mastery of these shortcuts is the difference between an average user and a 'Power User'. We strongly 
recommend you practice these shortcuts as they are explained in the tutorials, and wherever possible 
in your own projects. 
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File Shortcuts 

These are the pre-assigned keyboard shortcuts for the File menu (on page 45). 

User Interface Function Keyboard Shortcut 

Open a file CTRL+O 

Save a file CTRL+S 

Save a file with another name, in another format, and/or to 
another location 

CTRL+SHIFT+A 
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General Shortcuts 

These are the pre-assigned keyboard shortcuts for general procedures within the main user interface. 

User Interface Function Keyboard Shortcut 

Display the User Reference (online Help) F1 

Move to the next window CTRL+TAB 

Move to the previous window CTRL+SHIFT+TAB 

Redo last undone action CTRL+Y 

Undo last action CTRL+Z 
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Mapping Shortcuts 

These are the pre-assigned keyboard shortcuts for mapping UVs (on page 35). 

User Interface Function Keyboard Shortcut 

Leave interactive mapper ESC 
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Navigation Shortcuts 

These are the pre-assigned keyboard shortcuts for navigation procedures (on page 60). 

User Interface Function Keyboard Shortcut 

Move tool V 
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Selection Shortcuts 

These are the pre-assigned keyboard shortcuts for selection (on page 29) procedures. 

User Interface Function Keyboard Shortcut 

Add to selection Selection tool+SHIFT+click 

Clear all objects from selection CTRL+D 

Component Selection mode SHIFT+C 

Element Selection mode SHIFT+E 

Invert selection CTRL+SHIFT+I 

Lasso Selection tool L 

Point Selection mode SHIFT+P 

Polygon Selection mode SHIFT+O 

Polygon Wand Selection tool W 

Rectangular Selection tool M 

Select all objects CTRL+A 

Subtract from selection Selection tool+ALT+click 
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Transform Shortcuts 

These are the pre-assigned keyboard shortcuts for transform (on page 39) procedures. 

User Interface Function Keyboard Shortcut 

Close the free transform area ESC 

Free transform CTRL+T 
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View Menu Shortcuts 

These are the pre-assigned keyboard shortcuts for the View menu (on page 69). 

User Interface Function Keyboard Shortcut 

Display orthographic view from top SHIFT+T 

Display orthographic view from front SHIFT+F 

Display orthographic view from left SHIFT+L 

Display orthographic view from underneath SHIFT+U 

Display orthographic view from back SHIFT+B 

Display orthographic view from right SHIFT+R 

Toggle wireframe SHIFT+W 

Toggle palettes TAB 
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Appendix A: 2D File Formats 
The following supported 2D file formats are part of the standard application delivery. This list is 
organized alphabetically by file format. 

File Format Type Extension Import Export Version/Notes 

Adobe Photoshop Document Image PSD Yes Yes For users of Deep UV. 

Alias Image Image PIX Yes Yes  

Deep Paint 2D Image DP2 Yes Yes For users of Deep UV. 

Joint Photographic Experts Group 
Image 

Image JPEG, JPG Yes Yes  

Maya Interchange File Format Image IFF Yes *Yes *Requires Maya to be installed. 

Pbm Portable Bitmap Graphics  Image PNM  Yes Yes  

Portable Network Graphics Image PNG Yes Yes  

Raw RGB 24-bit Graphics  Image RAW Yes Yes  

Tagged Image File Format Image TIF, TIFF Yes Yes For users of Deep UV. 

Targa Image Image TGA Yes Yes  

Windows Bitmap Image BMP Yes Yes  

 
 

The following supported 3D file formats are part of the standard application delivery. This list is 
organized alphabetically by file format. 

File Format Extensio
n 

Import Export Version/Notes 

3D Studio 3DS Yes Yes  

3D Studio Project PRJ Yes   

4D Paint Project File 4DP Yes No For users of Deep UV. 

Deep UV File DP3 Yes Yes For users of Deep UV. 

LightWave Binary LW Yes Yes  

LightWave 3D Object LWO Yes Yes  

Right Hemisphere Binary RH Yes Yes Support for protected RH files (excluding export to 
Deep UV). 
Support for embedded images. 

Right Hemisphere Transfer RH3 Yes Yes  

SOFTIMAGE|XSI XSI Yes Yes  

Wavefront Object OBJ Yes Yes  
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